summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-02-09 11:45:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-02-09 11:45:18 +0000
commit8fd446768cdab53b58f65d5cae3755db3f9d673d (patch)
treeda132ae75b7dbe52e1b4f9f1365dbeada82bd6f4 /testing
parent329fa06ddd72e53143c6efda7f7792417a29714c (diff)
downloadaports-8fd446768cdab53b58f65d5cae3755db3f9d673d.tar.bz2
aports-8fd446768cdab53b58f65d5cae3755db3f9d673d.tar.xz
extra/{apr,apr-util,neon,subversion}: moved from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/apr-util/APKBUILD32
-rw-r--r--testing/apr/APKBUILD35
-rw-r--r--testing/neon/APKBUILD27
-rw-r--r--testing/subversion/APKBUILD37
-rw-r--r--testing/subversion/subversion.install10
-rw-r--r--testing/subversion/svnserve.confd10
-rw-r--r--testing/subversion/svnserve.initd44
7 files changed, 0 insertions, 195 deletions
diff --git a/testing/apr-util/APKBUILD b/testing/apr-util/APKBUILD
deleted file mode 100644
index e41878c3..00000000
--- a/testing/apr-util/APKBUILD
+++ /dev/null
@@ -1,32 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=apr-util
-pkgver=1.3.4
-pkgrel=0
-pkgdesc="The Apache Portable Runtime"
-url="http://apr.apache.org/"
-license="APACHE"
-depends="apr expat libuuid"
-subpackages="$pkgname-dev"
-makedepends="apr-dev expat-dev e2fsprogs-dev"
-source="http://www.apache.org/dist/apr/$pkgname-$pkgver.tar.bz2"
-
-build() {
- cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr \
- --with-apr=/usr \
- --without-pgsql \
- --without-mysql \
- --without-sqlite2 \
- --without-sqlite3 \
- --without-berkeley-db \
- --without-gdbm \
- --without-ldap-lib
-
- make || return 1
- make DESTDIR="$pkgdir" install
-
- # we dont need this one
- rm "$pkgdir"/usr/lib/*.exp
-}
-
-md5sums="adfbe525cf3914cf769340e8f6a6d14b apr-util-1.3.4.tar.bz2"
diff --git a/testing/apr/APKBUILD b/testing/apr/APKBUILD
deleted file mode 100644
index 275d6680..00000000
--- a/testing/apr/APKBUILD
+++ /dev/null
@@ -1,35 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=apr
-pkgver=1.3.3
-pkgrel=0
-pkgdesc="The Apache Portable Runtime"
-url="http://apr.apache.org/"
-license="APACHE"
-depends="libuuid"
-makedepends="e2fsprogs-dev"
-subpackages="$pkgname-dev"
-source="http://www.apache.org/dist/$pkgname/$pkgname-$pkgver.tar.bz2"
-
-build() {
- cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr \
- --datadir=/usr/share \
- --enable-nonportable-atomics \
- --with-devrandom=/dev/urandom
- make || return 1
- make DESTDIR=${pkgdir} install
-}
-
-# basicly everything thats not a *.so* file belongs to the -dev package
-# we override the pre-defined func.
-dev() {
- local i
- depends="$pkgname"
- mkdir -p "$subpkgdir"
- mv "$pkgdir"/* "$subpkgdir"/
- mkdir -p "$pkgdir"/usr/lib
- mv "$subpkgdir"/usr/lib/*.so* "$pkgdir"/usr/lib/
- return 0
-}
-
-md5sums="2090c21dee4f0eb1512604127dcd158f apr-1.3.3.tar.bz2"
diff --git a/testing/neon/APKBUILD b/testing/neon/APKBUILD
deleted file mode 100644
index e6af49c7..00000000
--- a/testing/neon/APKBUILD
+++ /dev/null
@@ -1,27 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=neon
-pkgver=0.28.3
-pkgrel=1
-pkgdesc="HTTP and WebDAV client library with a C interface"
-url="http://www.webdav.org/neon/"
-license="GPL LGPL"
-depends="openssl zlib expat"
-makedepends="expat-dev openssl-dev zlib-dev"
-subpackages="$pkgname-dev $pkgname-doc"
-source="http://www.webdav.org/$pkgname/$pkgname-$pkgver.tar.gz"
-
-build () {
- cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr \
- --with-ssl \
- --with-expat \
- --disable-gssapi \
- --disable-nls \
- --disable-socks \
- --enable-shared \
- --disable-static \
-
- make || return 1
- make DESTDIR="$pkgdir" install
-}
-md5sums="47599a328862ce64ac3c52726d6daa12 neon-0.28.3.tar.gz"
diff --git a/testing/subversion/APKBUILD b/testing/subversion/APKBUILD
deleted file mode 100644
index 463d6856..00000000
--- a/testing/subversion/APKBUILD
+++ /dev/null
@@ -1,37 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=subversion
-pkgver=1.5.5
-pkgrel=0
-pkgdesc="Replacement for CVS, another versioning system (svn)"
-url="http://subversion.tigris.org/"
-license="apache bsd"
-depends="apr apr-util expat neon openssl uclibc zlib"
-makedepends="apr-dev apr-util-dev expat-dev neon-dev openssl-dev zlib-dev
- e2fsprogs-dev libuuid"
-install="$pkgname.install"
-source="http://svn.collab.net/tarballs/$pkgname-$pkgver.tar.gz
- svnserve.confd
- svnserve.initd
- $install
- "
-
-build() {
- cd "$srcdir/$pkgname-$pkgver"
-
- ./configure --prefix=/usr \
- --disable-nls \
- --without-apxs \
- --disable-javahl \
- --without-jdk
-
- make external-all || return 1
- make local-all || return 1
- make -j1 DESTDIR="$pkgdir" install || return 1
-
- install -Dm755 "$srcdir"/svnserve.initd "$pkgdir"/etc/init.d/svnserve
- install -Dm644 "$srcdir"/svnserve.confd "$pkgdir"/etc/conf.d/svnserve
-}
-md5sums="532c7d49b3cd33d712289a5ef03b7749 subversion-1.5.5.tar.gz
-d084a7558053784886bc858b94fa9186 svnserve.confd
-06cf9328f63a935654971052a2c3594a svnserve.initd
-517b0819f3544df9dbee1f90f4289f34 subversion.install"
diff --git a/testing/subversion/subversion.install b/testing/subversion/subversion.install
deleted file mode 100644
index b61563cc..00000000
--- a/testing/subversion/subversion.install
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/sh
-
-case "$1" in
- pre_install)
- addgroup svnusers 2>/dev/null
- adduser svn -D -h /var/svn -G svnusers 2>/dev/null
- ;;
-esac
-exit 0
-
diff --git a/testing/subversion/svnserve.confd b/testing/subversion/svnserve.confd
deleted file mode 100644
index b487a409..00000000
--- a/testing/subversion/svnserve.confd
+++ /dev/null
@@ -1,10 +0,0 @@
-# The commented variables in this file are the defaults that are used
-# in the init-script. You don't need to uncomment them except to
-# customize them to different values.
-
-# Options for svnserve
-#SVNSERVE_OPTS="--root=/var/svn"
-
-# User and group as which to run svnserve
-SVNSERVE_USER="svn"
-SVNSERVE_GROUP="svnusers"
diff --git a/testing/subversion/svnserve.initd b/testing/subversion/svnserve.initd
deleted file mode 100644
index 036d0187..00000000
--- a/testing/subversion/svnserve.initd
+++ /dev/null
@@ -1,44 +0,0 @@
-#!/sbin/runscript
-# Copyright 2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/files/svnserve.initd,v 1.2 2005/08/25 13:59:48 pauldv Exp $
-
-opts="$opts setup"
-
-depend() {
- need net
-}
-
-start() {
- ebegin "Starting svnserve"
- # Ensure that we run from a readable working dir, and that we do not
- # lock filesystems when being run from such a location.
- cd /
- start-stop-daemon --start --quiet --background --make-pidfile \
- --pidfile /var/run/svnserve.pid --exec /usr/bin/svnserve \
- --chuid ${SVNSERVE_USER:-apache}:${SVNSERVE_GROUP:-apache} -- \
- --foreground --daemon ${SVNSERVE_OPTS:---root=/var/svn}
- eend $?
-}
-
-stop() {
- ebegin "Stopping svnserve"
- start-stop-daemon --stop --quiet --pidfile /var/run/svnserve.pid
- eend $?
-}
-
-setup() {
- local root=${SVNSERVE_ROOT:-/var/svn}
- ebeging "Setting up svnserve repositories in $root"
- if [ -e "$root/repos" ]; then
- eend 1 "$root/repos already exist"
- return 1
- fi
-
- svnadmin create "$root"/repos
- chown -Rf "${SVNSERVE_USER}:${SVNSERVE_GROUP}" "$root/repos"
- mkdir -p "$root/conf"
- chmod -Rf go-rwx "$root/conf"
- chmod -Rf o-rwx "$root/repos"
- eend $?
-}