summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2010-02-22 12:14:06 +0000
committerLeonardo Arena <rnalrd@gmail.com>2010-02-22 12:14:06 +0000
commite558ed22f63a6cc58506924726f2dd557898c63a (patch)
treea30c57a60dc466317148fb83b3b621c16d959eb5 /testing
parentc715f8a05f69f6850bb8bcc29f214cb76920c1ce (diff)
downloadaports-e558ed22f63a6cc58506924726f2dd557898c63a.tar.bz2
aports-e558ed22f63a6cc58506924726f2dd557898c63a.tar.xz
testing/parted: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/parted/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/parted/APKBUILD b/testing/parted/APKBUILD
new file mode 100644
index 00000000..eff3ac2b
--- /dev/null
+++ b/testing/parted/APKBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Leonardo Arena <rnalrd@gmail.com>
+pkgname=parted
+pkgver=1.9.0
+pkgrel=0
+pkgdesc="Creating, destroying, resizing, checking and copying partitions, and the file systems on them."
+url="http://www.gnu.org/software/parted"
+license="GPL"
+depends=
+makedepends="e2fsprogs-dev readline-dev"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+
+# append extra dependencies to -dev subpackage
+# remove if not used.
+# depends_dev="somepackage-dev"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sbindir=/sbin \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --disable-device-mapper
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+
+ # remove the 2 lines below (and this) if there is no init.d script
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="055305bc7bcf472ce38f9abf69a9d94d parted-1.9.0.tar.gz"