summaryrefslogtreecommitdiffstats
path: root/x11/libxpm
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-22 21:54:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-22 21:54:53 +0000
commit0d11a0b4dae7157945b2d7e991e04b76387118db (patch)
tree275d3d076cb9ec4cc4bea081820f96bdd1dca8d1 /x11/libxpm
parentfc1a0a54721ca0ca314ab5173d2bb864858af334 (diff)
downloadaports-0d11a0b4dae7157945b2d7e991e04b76387118db.tar.bz2
aports-0d11a0b4dae7157945b2d7e991e04b76387118db.tar.xz
x11/libxpm: update the depends
Diffstat (limited to 'x11/libxpm')
-rw-r--r--x11/libxpm/APKBUILD20
-rw-r--r--x11/libxpm/nocxx.patch15
2 files changed, 10 insertions, 25 deletions
diff --git a/x11/libxpm/APKBUILD b/x11/libxpm/APKBUILD
index bebd0f05..d1be1b73 100644
--- a/x11/libxpm/APKBUILD
+++ b/x11/libxpm/APKBUILD
@@ -1,27 +1,27 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libxpm
pkgver=3.5.8
-pkgrel=0
+pkgrel=1
pkgdesc="X11 pixmap library"
url="http://xorg.freedesktop.org/"
license="custom:BELL"
subpackages="$pkgname-dev $pkgname-doc"
-depends="libxt libxext libx11 uclibc"
-makedepends="pkgconfig libxt-dev libxext-dev libx11-dev e2fsprogs-dev"
-source="http://xorg.freedesktop.org/releases/individual/lib/libXpm-$pkgver.tar.bz2
- nocxx.patch"
+depends=
+makedepends="pkgconfig libxt-dev libxext-dev libx11-dev util-linux-ng-dev"
+source="http://xorg.freedesktop.org/releases/individual/lib/libXpm-$pkgver.tar.bz2"
depends_dev="libx11-dev"
-build ()
-{
+build() {
cd "$srcdir"/libXpm-$pkgver
- patch configure < ../nocxx.patch
./configure --prefix=/usr \
--sysconfdir=/etc \
|| return 1
make || return 1
+}
+
+package() {
+ cd "$srcdir"/libXpm-$pkgver
make DESTDIR="$pkgdir" install || return 1
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-md5sums="38e58e72d476a74298a59052fde185a3 libXpm-3.5.8.tar.bz2
-28513788ba4d556ccd538867dc6205ab nocxx.patch"
+md5sums="38e58e72d476a74298a59052fde185a3 libXpm-3.5.8.tar.bz2"
diff --git a/x11/libxpm/nocxx.patch b/x11/libxpm/nocxx.patch
deleted file mode 100644
index beb1ab90..00000000
--- a/x11/libxpm/nocxx.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/configure 2004-12-07 21:34:23.205172545 +0000
-+++ b/configure 2004-12-07 21:37:17.726654782 +0000
-@@ -5148,10 +5148,8 @@
- :
- else
- { { echo "$as_me:$LINENO: error: C++ preprocessor \"$CXXCPP\" fails sanity check
--See \`config.log' for more details." >&5
--echo "$as_me: error: C++ preprocessor \"$CXXCPP\" fails sanity check
--See \`config.log' for more details." >&2;}
-- { (exit 1); exit 1; }; }
-+See \`config.log' for more details." >&5;}
-+ { echo "C++ sucks, ignoring ..." >&5; }; }
- fi
-
- ac_ext=cc