summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/ghostscript/APKBUILD55
-rw-r--r--main/ghostscript/ghostscript-system-jasper.patch26
-rw-r--r--main/ghostscript/libpng14.patch24
-rw-r--r--main/git/APKBUILD6
-rw-r--r--main/imagemagick/APKBUILD5
-rw-r--r--main/ipsec-tools/APKBUILD6
-rw-r--r--main/ipsec-tools/fd-priorities.patch285
-rw-r--r--main/m4/APKBUILD13
-rw-r--r--main/sudo/APKBUILD6
-rw-r--r--testing/libwmf/APKBUILD35
-rw-r--r--testing/libwmf/libpng14.patch12
11 files changed, 443 insertions, 30 deletions
diff --git a/main/ghostscript/APKBUILD b/main/ghostscript/APKBUILD
index 51c37016..ad414e58 100644
--- a/main/ghostscript/APKBUILD
+++ b/main/ghostscript/APKBUILD
@@ -1,45 +1,70 @@
# Contributor: Cameron Banta <cbanta@gmail.com>
# Maintainer: Cameron Banta <cbanta@gmail.com>
pkgname=ghostscript
-pkgver=8.70
+pkgver=8.71
pkgrel=0
pkgdesc="An interpreter for the PostScript language and for PDF"
url="http://ghostscript.com/"
license="GPL"
-depends="uclibc"
-makedepends=""
-install=
-subpackages="$pkgname-doc"
-source="http://ghostscript.com/releases/$pkgname-$pkgver.tar.gz"
+makedepends="autoconf automake jpeg-dev libpng-dev jasper-dev expat-dev zlib-dev tiff-dev libiconv-dev"
+subpackages="$pkgname-doc $pkgname-dev"
+source="http://ghostscript.com/releases/$pkgname-$pkgver.tar.gz
+ libpng14.patch
+ ghostscript-system-jasper.patch"
-build() {
+prepare() {
cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr \
+ # force it to use system-libs
+ rm -rf jpeg libpng jasper expat tiff
+
+ patch -Np1 -i "${srcdir}"/libpng14.patch || return 1
+
+ # fix build with systems jasper
+ patch -Np1 -i "${srcdir}"/ghostscript-system-jasper.patch || return 1
+
+ ./autogen.sh \
+ --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
+ --docdir=/usr/share/doc/"$pkgname" \
+ --enable-dynamic \
+ --with-system-libtiff \
+ --without-ijs --without-x \
+ --with-jbig2dec \
+ --without-omni \
--with-drivers=FILES \
+ --with-fontpath=/usr/share/fonts/Type1:/usr/share/fonts \
--disable-cups --disable-gtk --disable-cairo \
- --docdir=/usr/share/doc/"$pkgname"
+ --disable-compile-inits # needed for linking with system-zlib
+}
+
+build(){
+ cd "$srcdir/$pkgname-$pkgver"
make || return 1
- make DESTDIR="$pkgdir" install
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make -j1 DESTDIR="${pkgdir}" install soinstall || return 1
+
+ #create empty dir for future fonts
+ mkdir -p "${pkgdir}"/usr/share/fonts/Type1
# license and copying
install -m644 -D "$srcdir/$pkgname-$pkgver/LICENSE" \
"$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -m644 -D "$srcdir/$pkgname-$pkgver/doc/COPYING" \
"$pkgdir/usr/share/licenses/$pkgname/COPYING"
-
-
# make the doc and examples more alpine like
# (the --docdir above doesn't seem to work so good)
mkdir -p "$pkgdir/usr/share/doc/$pkgname"
mv "$pkgdir/usr/share/$pkgname/$pkgver/doc" "$pkgdir/usr/share/doc/$pkgname"
mv "$pkgdir/usr/share/$pkgname/$pkgver/examples" "$pkgdir/usr/share/doc/$pkgname"
-
-
}
-md5sums="be2581eb1ba9e4ab67c2eda95144d564 ghostscript-8.70.tar.gz"
+md5sums="51a522a5b4818bd3dc7c1c0e9dd22bad ghostscript-8.71.tar.gz
+be94ee357986f7f63d1b470da5bdc99e libpng14.patch
+03e27cd02471ab3b642c344fa06b623e ghostscript-system-jasper.patch"
diff --git a/main/ghostscript/ghostscript-system-jasper.patch b/main/ghostscript/ghostscript-system-jasper.patch
new file mode 100644
index 00000000..444b7602
--- /dev/null
+++ b/main/ghostscript/ghostscript-system-jasper.patch
@@ -0,0 +1,26 @@
+diff -up ghostscript-8.64/base/sjpx.c.system-jasper ghostscript-8.64/base/sjpx.c
+--- ghostscript-8.64/base/sjpx.c.system-jasper 2008-08-21 00:22:49.000000000 +0100
++++ ghostscript-8.64/base/sjpx.c 2009-02-04 11:35:56.000000000 +0000
+@@ -34,14 +34,6 @@ static void s_jpxd_set_defaults(stream_s
+ private_st_jpxd_state(); /* creates a gc object for our state,
+ defined in sjpx.h */
+
+-/* error reporting callback for the jpx library */
+-static void
+-s_jpx_jas_error_cb(jas_error_t err, char *msg)
+-{
+- dprintf2("jasper (code %d) %s", (int)err, msg);
+-}
+-
+-
+ /* initialize the steam.
+ this involves allocating the stream and image structures, and
+ initializing the decoder.
+@@ -59,7 +51,6 @@ s_jpxd_init(stream_state * ss)
+ }
+
+ status = jas_init();
+- jas_set_error_cb(s_jpx_jas_error_cb);
+ #ifdef JPX_DEBUG
+ /* raise the error reporting threshold from the default (0) */
+ jas_setdbglevel(1);
diff --git a/main/ghostscript/libpng14.patch b/main/ghostscript/libpng14.patch
new file mode 100644
index 00000000..7ee08af9
--- /dev/null
+++ b/main/ghostscript/libpng14.patch
@@ -0,0 +1,24 @@
+diff -Nur ghostscript-8.70.orig/base/configure.ac ghostscript-8.70/base/configure.ac
+--- ghostscript-8.70.orig/base/configure.ac 2009-07-27 19:59:50.000000000 +0300
++++ ghostscript-8.70/base/configure.ac 2010-01-17 02:20:52.000000000 +0200
+@@ -402,7 +402,7 @@
+ PNGDEVS="$PNGDEVS_ALL"
+ else
+ AC_MSG_RESULT([no])
+- AC_CHECK_LIB(png, png_check_sig, [
++ AC_CHECK_LIB(png, png_sig_cmp, [
+ AC_CHECK_HEADERS(png.h, [
+ SHARE_LIBPNG=1
+ PNGDEVS="$PNGDEVS_ALL"
+diff -Nur ghostscript-8.70.orig/jbig2dec/configure.ac ghostscript-8.70/jbig2dec/configure.ac
+--- ghostscript-8.70.orig/jbig2dec/configure.ac 2009-05-29 09:48:44.000000000 +0300
++++ ghostscript-8.70/jbig2dec/configure.ac 2010-01-17 02:21:25.000000000 +0200
+@@ -34,7 +34,7 @@
+ fi
+ dnl libpng requires pow() which may be in libm
+ AC_SEARCH_LIBS([pow], [m])
+- AC_CHECK_LIB([png], [png_check_sig], [
++ AC_CHECK_LIB([png], [png_sig_cmp], [
+ AC_CHECK_LIB([z], [deflate], [
+ AC_DEFINE(HAVE_LIBPNG, 1, [Define if libpng is available (-lpng)])
+ LIBS="-lpng -lz $LIBS"
diff --git a/main/git/APKBUILD b/main/git/APKBUILD
index d16e4091..da1fa012 100644
--- a/main/git/APKBUILD
+++ b/main/git/APKBUILD
@@ -1,13 +1,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=git
-pkgver=1.6.6.1
+pkgver=1.7.0.2
pkgrel=0
pkgdesc="GIT - the stupid content tracker"
url="http://git.or.cz/"
license="GPL2"
depends=
subpackages="$pkgname-doc $pkgname-perl"
-makedepends="zlib-dev openssl-dev curl-dev expat-dev perl-dev"
+makedepends="zlib-dev openssl-dev curl-dev expat-dev perl-dev python-dev"
source="http://kernel.org/pub/software/scm/git/git-$pkgver.tar.bz2
bb-tar.patch
"
@@ -42,5 +42,5 @@ perl() {
}
-md5sums="9d254bfdae56c6fa124d8a1312a1b034 git-1.6.6.1.tar.bz2
+md5sums="76518fa774b36de81d160b85fa4f19c1 git-1.7.0.2.tar.bz2
e63a201556c4f089de790805c09a2e5b bb-tar.patch"
diff --git a/main/imagemagick/APKBUILD b/main/imagemagick/APKBUILD
index 9f0d05ee..a50ffb35 100644
--- a/main/imagemagick/APKBUILD
+++ b/main/imagemagick/APKBUILD
@@ -3,12 +3,12 @@
pkgname=imagemagick
pkgver=6.5.9.0
_pkgver=${pkgver%.*}-${pkgver##*.}
-pkgrel=2
+pkgrel=3
pkgdesc="A collection of tools and libraries for many image formats"
url="http://www.imagemagick.org/"
license="GPL"
depends=
-makedepends="zlib-dev libpng-dev jpeg-dev freetype-dev perl-dev"
+makedepends="zlib-dev libpng-dev jpeg-dev freetype-dev perl-dev ghostscript-dev"
subpackages="$pkgname-doc $pkgname-dev"
source="ftp://ftp.imagemagick.org/pub/ImageMagick/ImageMagick-$_pkgver.tar.gz"
@@ -26,6 +26,7 @@ build() {
--infodir=/usr/share/info \
--without-threads \
--without-x \
+ --with-gslib \
--with-modules
make || return 1
}
diff --git a/main/ipsec-tools/APKBUILD b/main/ipsec-tools/APKBUILD
index b0197347..a3da4fc1 100644
--- a/main/ipsec-tools/APKBUILD
+++ b/main/ipsec-tools/APKBUILD
@@ -2,7 +2,7 @@
pkgname=ipsec-tools
pkgver=0.8_alpha20090903
_myver=0.8-alpha20090903
-pkgrel=5
+pkgrel=6
pkgdesc="User-space IPsec tools for various IPsec implementations"
url="http://ipsec-tools.sourceforge.net/"
license="BSD"
@@ -15,6 +15,7 @@ source="http://downloads.sourceforge.net/$pkgname/$pkgname-$_myver.tar.gz
50-reverse-connect.patch
60-debug-quick.patch
initial-contact-fix.diff
+ fd-priorities.patch
"
_builddir="$srcdir"/$pkgname-$_myver
@@ -60,4 +61,5 @@ md5sums="8ec28d4e89c0f5e49ae2caa7463fbcfd ipsec-tools-0.8-alpha20090903.tar.gz
2d00250cf72da7f2f559c91b65a48747 racoon.confd
13bda94a598aabf593280e04ea16065d 50-reverse-connect.patch
baa13d7f0f48955c792f7fcd42a8587a 60-debug-quick.patch
-69e06c5cc3a0c1cc8b10ddc89d1e644b initial-contact-fix.diff"
+69e06c5cc3a0c1cc8b10ddc89d1e644b initial-contact-fix.diff
+c1e8b8dc80ef4b5d79fece52a4865e68 fd-priorities.patch"
diff --git a/main/ipsec-tools/fd-priorities.patch b/main/ipsec-tools/fd-priorities.patch
new file mode 100644
index 00000000..68fc4b34
--- /dev/null
+++ b/main/ipsec-tools/fd-priorities.patch
@@ -0,0 +1,285 @@
+? .msg
+? ChangeLog
+? alpine-config
+? commiters.txt
+? fd-priorities-2.patch
+? fd-priorities.patch
+? ipsec-tools-0.8-alpha20090820.tar.bz2
+? ipsec-tools-0.8-alpha20090903.tar.bz2
+? local-changes.diff
+? patch-to-support-cast128-cbc-algorithm.patch
+? racoon.txt
+? rpm/Makefile
+? rpm/Makefile.in
+? rpm/ipsec-tools.spec
+? rpm/suse/Makefile
+? rpm/suse/Makefile.in
+? rpm/suse/ipsec-tools.spec
+? src/Makefile
+? src/Makefile.in
+? src/include-glibc/.includes
+? src/include-glibc/Makefile
+? src/include-glibc/Makefile.in
+? src/libipsec/.deps
+? src/libipsec/.libs
+? src/libipsec/Makefile
+? src/libipsec/Makefile.in
+? src/libipsec/ipsec_dump_policy.lo
+? src/libipsec/ipsec_get_policylen.lo
+? src/libipsec/ipsec_strerror.lo
+? src/libipsec/key_debug.lo
+? src/libipsec/libipsec.la
+? src/libipsec/pfkey.lo
+? src/libipsec/pfkey_dump.lo
+? src/libipsec/policy_parse.c
+? src/libipsec/policy_parse.h
+? src/libipsec/policy_parse.lo
+? src/libipsec/policy_token.c
+? src/libipsec/policy_token.lo
+? src/racoon/.deps
+? src/racoon/.libs
+? src/racoon/Makefile
+? src/racoon/Makefile.in
+? src/racoon/cfparse.c
+? src/racoon/cfparse.h
+? src/racoon/cftoken.c
+? src/racoon/eaytest
+? src/racoon/libracoon.la
+? src/racoon/libracoon_la-kmpstat.lo
+? src/racoon/libracoon_la-misc.lo
+? src/racoon/libracoon_la-sockmisc.lo
+? src/racoon/libracoon_la-vmbuf.lo
+? src/racoon/plainrsa-gen
+? src/racoon/prsa_par.c
+? src/racoon/prsa_par.h
+? src/racoon/prsa_tok.c
+? src/racoon/racoon
+? src/racoon/racoonctl
+? src/racoon/samples/psk.txt
+? src/racoon/samples/racoon.conf
+? src/setkey/.deps
+? src/setkey/.libs
+? src/setkey/Makefile
+? src/setkey/Makefile.in
+? src/setkey/parse.c
+? src/setkey/parse.h
+? src/setkey/setkey
+? src/setkey/token.c
+Index: src/racoon/admin.c
+===================================================================
+RCS file: /cvsroot/src/crypto/dist/ipsec-tools/src/racoon/admin.c,v
+retrieving revision 1.32
+diff -u -r1.32 admin.c
+--- a/src/racoon/admin.c 3 Sep 2009 09:29:07 -0000 1.32
++++ b/src/racoon/admin.c 9 Mar 2010 07:50:46 -0000
+@@ -734,7 +734,7 @@
+ return -1;
+ }
+
+- monitor_fd(lcconf->sock_admin, admin_handler, NULL);
++ monitor_fd(lcconf->sock_admin, admin_handler, NULL, 0);
+ plog(LLV_DEBUG, LOCATION, NULL,
+ "open %s as racoon management.\n", sunaddr.sun_path);
+
+Index: src/racoon/evt.c
+===================================================================
+RCS file: /cvsroot/src/crypto/dist/ipsec-tools/src/racoon/evt.c,v
+retrieving revision 1.9
+diff -u -r1.9 evt.c
+--- a/src/racoon/evt.c 23 Jan 2009 08:05:58 -0000 1.9
++++ b/src/racoon/evt.c 9 Mar 2010 07:50:46 -0000
+@@ -373,7 +373,7 @@
+
+ LIST_INSERT_HEAD(list, l, ll_chain);
+ l->fd = fd;
+- monitor_fd(l->fd, evt_unsubscribe_cb, l);
++ monitor_fd(l->fd, evt_unsubscribe_cb, l, 0);
+
+ plog(LLV_DEBUG, LOCATION, NULL,
+ "[%d] admin connection is polling events\n", fd);
+Index: src/racoon/grabmyaddr.c
+===================================================================
+RCS file: /cvsroot/src/crypto/dist/ipsec-tools/src/racoon/grabmyaddr.c,v
+retrieving revision 1.23
+diff -u -r1.23 grabmyaddr.c
+--- a/src/racoon/grabmyaddr.c 3 Jul 2009 06:41:46 -0000 1.23
++++ b/src/racoon/grabmyaddr.c 9 Mar 2010 07:50:46 -0000
+@@ -296,7 +296,7 @@
+ lcconf->rtsock = kernel_open_socket();
+ if (lcconf->rtsock < 0)
+ return -1;
+- monitor_fd(lcconf->rtsock, kernel_receive, NULL);
++ monitor_fd(lcconf->rtsock, kernel_receive, NULL, 0);
+ } else {
+ lcconf->rtsock = -1;
+ if (!myaddr_open_all_configured(NULL))
+Index: src/racoon/isakmp.c
+===================================================================
+RCS file: /cvsroot/src/crypto/dist/ipsec-tools/src/racoon/isakmp.c,v
+retrieving revision 1.60
+diff -u -r1.60 isakmp.c
+--- a/src/racoon/isakmp.c 3 Sep 2009 09:29:07 -0000 1.60
++++ b/src/racoon/isakmp.c 9 Mar 2010 07:50:48 -0000
+@@ -1720,7 +1720,7 @@
+ "%s used as isakmp port (fd=%d)\n",
+ saddr2str(addr), fd);
+
+- monitor_fd(fd, isakmp_handler, NULL);
++ monitor_fd(fd, isakmp_handler, NULL, 1);
+ return fd;
+
+ err:
+Index: src/racoon/pfkey.c
+===================================================================
+RCS file: /cvsroot/src/crypto/dist/ipsec-tools/src/racoon/pfkey.c,v
+retrieving revision 1.52
+diff -u -r1.52 pfkey.c
+--- a/src/racoon/pfkey.c 9 Feb 2010 23:05:16 -0000 1.52
++++ b/src/racoon/pfkey.c 9 Mar 2010 07:50:49 -0000
+@@ -487,7 +487,7 @@
+ return -1;
+ }
+ #endif
+- monitor_fd(lcconf->sock_pfkey, pfkey_handler, NULL);
++ monitor_fd(lcconf->sock_pfkey, pfkey_handler, NULL, 0);
+ return 0;
+ }
+
+Index: src/racoon/session.c
+===================================================================
+RCS file: /cvsroot/src/crypto/dist/ipsec-tools/src/racoon/session.c,v
+retrieving revision 1.27
+diff -u -r1.27 session.c
+--- a/src/racoon/session.c 4 Mar 2010 15:13:53 -0000 1.27
++++ b/src/racoon/session.c 9 Mar 2010 07:50:50 -0000
+@@ -103,8 +103,13 @@
+ struct fd_monitor {
+ int (*callback)(void *ctx, int fd);
+ void *ctx;
++ int prio;
++ int fd;
++ TAILQ_ENTRY(fd_monitor) chain;
+ };
+
++#define NUM_PRIORITIES 2
++
+ static void close_session __P((void));
+ static void initfds __P((void));
+ static void init_signal __P((void));
+@@ -115,13 +120,14 @@
+
+ static fd_set preset_mask, active_mask;
+ static struct fd_monitor fd_monitors[FD_SETSIZE];
++static TAILQ_HEAD(fd_monitor_list, fd_monitor) fd_monitor_tree[NUM_PRIORITIES];
+ static int nfds = 0;
+
+ static volatile sig_atomic_t sigreq[NSIG + 1];
+ static struct sched scflushsa = SCHED_INITIALIZER();
+
+ void
+-monitor_fd(int fd, int (*callback)(void *, int), void *ctx)
++monitor_fd(int fd, int (*callback)(void *, int), void *ctx, int priority)
+ {
+ if (fd < 0 || fd >= FD_SETSIZE) {
+ plog(LLV_ERROR, LOCATION, NULL, "fd_set overrun");
+@@ -131,9 +137,17 @@
+ FD_SET(fd, &preset_mask);
+ if (fd > nfds)
+ nfds = fd;
++ if (priority <= 0)
++ priority = 0;
++ if (priority >= NUM_PRIORITIES)
++ priority = NUM_PRIORITIES - 1;
+
+ fd_monitors[fd].callback = callback;
+ fd_monitors[fd].ctx = ctx;
++ fd_monitors[fd].prio = priority;
++ fd_monitors[fd].fd = fd;
++ TAILQ_INSERT_TAIL(&fd_monitor_tree[priority],
++ &fd_monitors[fd], chain);
+ }
+
+ void
+@@ -144,10 +158,15 @@
+ exit(1);
+ }
+
++ if (fd_monitors[fd].callback == NULL)
++ return;
++
+ FD_CLR(fd, &preset_mask);
+ FD_CLR(fd, &active_mask);
+ fd_monitors[fd].callback = NULL;
+ fd_monitors[fd].ctx = NULL;
++ TAILQ_REMOVE(&fd_monitor_tree[fd_monitors[fd].prio],
++ &fd_monitors[fd], chain);
+ }
+
+ int
+@@ -158,11 +177,15 @@
+ char pid_file[MAXPATHLEN];
+ FILE *fp;
+ pid_t racoon_pid = 0;
+- int i;
++ int i, count;
++ struct fd_monitor *fdm;
+
+ nfds = 0;
+ FD_ZERO(&preset_mask);
+
++ for (i = 0; i < NUM_PRIORITIES; i++)
++ TAILQ_INIT(&fd_monitor_tree[i]);
++
+ /* initialize schedular */
+ sched_init();
+ init_signal();
+@@ -291,16 +314,24 @@
+ /*NOTREACHED*/
+ }
+
+- for (i = 0; i <= nfds; i++) {
+- if (!FD_ISSET(i, &active_mask))
+- continue;
+-
+- if (fd_monitors[i].callback != NULL)
+- fd_monitors[i].callback(fd_monitors[i].ctx, i);
+- else
+- plog(LLV_ERROR, LOCATION, NULL,
+- "fd %d set, but no active callback\n", i);
++ count = 0;
++ for (i = 0; i < NUM_PRIORITIES; i++) {
++ TAILQ_FOREACH(fdm, &fd_monitor_tree[i], chain) {
++ if (!FD_ISSET(fdm->fd, &active_mask))
++ continue;
++
++ FD_CLR(fdm->fd, &active_mask);
++ if (fdm->callback != NULL) {
++ fdm->callback(fdm->ctx, fdm->fd);
++ count++;
++ } else
++ plog(LLV_ERROR, LOCATION, NULL,
++ "fd %d set, but no active callback\n", i);
++ }
++ if (count != 0)
++ break;
+ }
++
+ }
+ }
+
+Index: src/racoon/session.h
+===================================================================
+RCS file: /cvsroot/src/crypto/dist/ipsec-tools/src/racoon/session.h,v
+retrieving revision 1.8
+diff -u -r1.8 session.h
+--- a/src/racoon/session.h 23 Jan 2009 08:05:58 -0000 1.8
++++ b/src/racoon/session.h 9 Mar 2010 07:50:50 -0000
+@@ -37,7 +37,7 @@
+ extern int session __P((void));
+ extern RETSIGTYPE signal_handler __P((int));
+
+-extern void monitor_fd __P((int fd, int (*callback)(void *, int), void *ctx));
++extern void monitor_fd __P((int fd, int (*callback)(void *, int), void *ctx, int priority));
+ extern void unmonitor_fd __P((int fd));
+
+ #endif /* _SESSION_H */
diff --git a/main/m4/APKBUILD b/main/m4/APKBUILD
index 65a998ea..0d5a63e8 100644
--- a/main/m4/APKBUILD
+++ b/main/m4/APKBUILD
@@ -3,18 +3,21 @@ pkgname=m4
pkgver=1.4.13
pkgrel=0
pkgdesc="GNU macro processor"
-arch=i486
url="http://www.gnu.org/software/m4"
source=ftp://ftp.gnu.org/gnu/m4/$pkgname-$pkgver.tar.gz
-depends=uclibc
-license=GPL
+depends=
+license="GPL"
subpackages="m4-doc"
-origin="core/$pkgname"
+_builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd $srcdir/$pkgname-$pkgver
+ cd "$_builddir"
./configure --prefix=/usr
make
+}
+
+package() {
+ cd "$_builddir"
make install DESTDIR="$pkgdir"
}
diff --git a/main/sudo/APKBUILD b/main/sudo/APKBUILD
index 13fd74ac..1e4641c9 100644
--- a/main/sudo/APKBUILD
+++ b/main/sudo/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=sudo
-pkgver=1.7.2_p2
-_realver=1.7.2p2
+pkgver=1.7.2_p4
+_realver=1.7.2p4
pkgrel=0
pkgdesc="Give certain users the ability to run some commands as root"
url="http://www.sudo.ws/sudo/"
@@ -27,4 +27,4 @@ package() {
make -j1 DESTDIR="$pkgdir" install || return 1
}
-md5sums="2a19cf1ab4afc94fe19d0d0899d4cd45 sudo-1.7.2p2.tar.gz"
+md5sums="3989e5a00538247d7dcef8b514076752 sudo-1.7.2p4.tar.gz"
diff --git a/testing/libwmf/APKBUILD b/testing/libwmf/APKBUILD
new file mode 100644
index 00000000..3f410879
--- /dev/null
+++ b/testing/libwmf/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libwmf
+pkgver=0.2.8.4
+pkgrel=0
+pkgdesc="A library for reading vector images in Microsoft's native Windows Metafile Format (WMF)."
+url="http://wvware.sourceforge.net/libwmf.html"
+license="LGPL"
+makedepends="libpng-dev>=1.4.0 freetype-dev jpeg-dev>=8 expat-dev"
+install=
+subpackages="$pkgname-dev"
+source="http://downloads.sourceforge.net/sourceforge/wvware/$pkgname-$pkgver.tar.gz
+ libpng14.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ patch -Np1 -i ""$srcdir"/libpng14.patch" || return 1
+ sed -i -e 's/src include fonts doc/src include fonts/g' Makefile.in
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --with-gsfontdir=/usr/share/fonts/Type1 \
+ --with-fontdir=/usr/share/fonts/Type1 \
+ --with-gsfontmap=/usr/share/ghostscript/8.15/lib/Fontmap.GS
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install
+}
+md5sums="d1177739bf1ceb07f57421f0cee191e0 libwmf-0.2.8.4.tar.gz
+33d3c07a1be9f99fd88de220930c5550 libpng14.patch"
diff --git a/testing/libwmf/libpng14.patch b/testing/libwmf/libpng14.patch
new file mode 100644
index 00000000..3d38c717
--- /dev/null
+++ b/testing/libwmf/libpng14.patch
@@ -0,0 +1,12 @@
+diff -Nur libwmf-0.2.8.4.orig/src/extra/gd/gd_png.c libwmf-0.2.8.4/src/extra/gd/gd_png.c
+--- libwmf-0.2.8.4.orig/src/extra/gd/gd_png.c 2005-07-27 23:35:06.000000000 +0300
++++ libwmf-0.2.8.4/src/extra/gd/gd_png.c 2010-01-17 01:33:58.000000000 +0200
+@@ -136,7 +136,7 @@
+ /* first do a quick check that the file really is a PNG image; could
+ * have used slightly more general png_sig_cmp() function instead */
+ gdGetBuf (sig, 8, infile);
+- if (!png_check_sig (sig, 8))
++ if (png_sig_cmp (sig, 0, 8))
+ return NULL; /* bad signature */
+
+ #ifndef PNG_SETJMP_NOT_SUPPORTED