summaryrefslogtreecommitdiffstats
path: root/extra/pth
diff options
context:
space:
mode:
Diffstat (limited to 'extra/pth')
-rw-r--r--extra/pth/APKBUILD35
-rw-r--r--extra/pth/pth-2.0.5-parallelfix.patch15
-rw-r--r--extra/pth/pth-2.0.6-ldflags.patch17
-rw-r--r--extra/pth/pth-2.0.6-sigstack.patch22
4 files changed, 0 insertions, 89 deletions
diff --git a/extra/pth/APKBUILD b/extra/pth/APKBUILD
deleted file mode 100644
index ce5cc5e1..00000000
--- a/extra/pth/APKBUILD
+++ /dev/null
@@ -1,35 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=pth
-pkgver=2.0.7
-pkgrel=0
-pkgdesc="The GNU Portable Threads."
-url="http://www.gnu.org/software/pth"
-license="LGPL-2.1"
-depends="uclibc"
-subpackages="$pkgname-dev $pkgname-doc"
-source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz
- pth-2.0.5-parallelfix.patch
- pth-2.0.6-ldflags.patch
- pth-2.0.6-sigstack.patch
- "
-
-build () {
- cd "$srcdir"/$pkgname-$pkgver
-
- for i in ../*.patch; do
- msg "Applying $i..."
- patch -p1 < $i || return 1
- done
-
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/share/man
-
- make || return 1
- make -j1 DESTDIR="$pkgdir" install
-}
-md5sums="9cb4a25331a4c4db866a31cbe507c793 pth-2.0.7.tar.gz
-7bbd4f3328807c740c86db94e93e48ad pth-2.0.5-parallelfix.patch
-942fa4be28117756cd579937b257b9cc pth-2.0.6-ldflags.patch
-04e43157d758a3dc7925c35e6dd1e39c pth-2.0.6-sigstack.patch"
diff --git a/extra/pth/pth-2.0.5-parallelfix.patch b/extra/pth/pth-2.0.5-parallelfix.patch
deleted file mode 100644
index 1c8200a4..00000000
--- a/extra/pth/pth-2.0.5-parallelfix.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/Makefile.in 2005-11-08 05:58:55.000000000 +1100
-+++ b/Makefile.in 2005-11-08 06:29:02.000000000 +1100
-@@ -148,10 +148,9 @@
-
- # be aware of libtool when building the objects
- .SUFFIXES:
--.SUFFIXES: .c .o .lo
--.c.o:
-+%.o: %.c $(TARGET_PREQ)
- $(CC) -c $(CPPFLAGS) $(CFLAGS) $<
--.c.lo:
-+%.lo: %.c $(TARGET_PREQ)
- $(LIBTOOL) --mode=compile --quiet $(CC) -c $(CPPFLAGS) $(CFLAGS) $<
-
- # the default target
diff --git a/extra/pth/pth-2.0.6-ldflags.patch b/extra/pth/pth-2.0.6-ldflags.patch
deleted file mode 100644
index 7a4a5ab3..00000000
--- a/extra/pth/pth-2.0.6-ldflags.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Index: pth-2.0.6/Makefile.in
-===================================================================
---- pth-2.0.6.orig/Makefile.in
-+++ pth-2.0.6/Makefile.in
-@@ -168,10 +168,10 @@ pth_p.h: $(S)pth_p.h.in
-
- # build the static and possibly shared libraries
- libpth.la: $(LOBJS)
-- $(LIBTOOL) --mode=link --quiet $(CC) -o libpth.la $(LOBJS) \
-+ $(LIBTOOL) --mode=link --quiet $(CC) $(LDFLAGS) -o libpth.la $(LOBJS) \
- -rpath $(libdir) -version-info `$(SHTOOL) version -lc -dlibtool $(_VERSION_FILE)`
- libpthread.la: pthread.lo $(LOBJS)
-- $(LIBTOOL) --mode=link --quiet $(CC) -o libpthread.la pthread.lo $(LOBJS) \
-+ $(LIBTOOL) --mode=link --quiet $(CC) $(LDFLAGS) -o libpthread.la pthread.lo $(LOBJS) \
- -rpath $(libdir) -version-info `$(SHTOOL) version -lc -dlibtool $(_VERSION_FILE)`
-
- # build the manual pages
diff --git a/extra/pth/pth-2.0.6-sigstack.patch b/extra/pth/pth-2.0.6-sigstack.patch
deleted file mode 100644
index 3914dea7..00000000
--- a/extra/pth/pth-2.0.6-sigstack.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -urNp pth-2.0.6.old/aclocal.m4 pth-2.0.6/aclocal.m4
---- pth-2.0.6.old/aclocal.m4 2004-12-31 21:33:19.000000000 +0200
-+++ pth-2.0.6/aclocal.m4 2006-09-20 14:46:59.000000000 +0300
-@@ -1522,6 +1522,7 @@ int main(int argc, char *argv[])
- int sksize;
- char result[1024];
- int i;
-+exit (1);
- sksize = 32768;
- skbuf = (char *)malloc(sksize*2+2*sizeof(union alltypes));
- if (skbuf == NULL)
-diff -urNp pth-2.0.6.old/configure pth-2.0.6/configure
---- pth-2.0.6.old/configure 2005-11-22 09:49:21.000000000 +0200
-+++ pth-2.0.6/configure 2006-09-20 14:55:23.000000000 +0300
-@@ -24735,6 +24735,7 @@ int main(int argc, char *argv[])
- int sksize;
- char result[1024];
- int i;
-+exit (1);
- sksize = 32768;
- skbuf = (char *)malloc(sksize*2+2*sizeof(union alltypes));
- if (skbuf == NULL)