summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/xe-guest-utilities/APKBUILD9
-rw-r--r--main/xe-guest-utilities/xe-update-guest-attrs_466.patch32
2 files changed, 38 insertions, 3 deletions
diff --git a/main/xe-guest-utilities/APKBUILD b/main/xe-guest-utilities/APKBUILD
index 02b2115b..39b110e8 100644
--- a/main/xe-guest-utilities/APKBUILD
+++ b/main/xe-guest-utilities/APKBUILD
@@ -2,7 +2,8 @@
# Maintainer: Cedric Schieli <cschieli@gmail.com>
pkgname=xe-guest-utilities
_major=5.5.0
-_minor=458
+_minor=466
+_srcminor=458
pkgver=${_major}.${_minor}
pkgrel=0
pkgdesc="XenServer guest tools"
@@ -12,12 +13,13 @@ depends=
makedepends=
install=
subpackages=
-source="http://updates.vmd.citrix.com/XenServer/${_major}/debian/pool/main/x/${pkgname}/${pkgname}_${_major}-${_minor}.tar.gz
+source="http://updates.vmd.citrix.com/XenServer/${_major}/debian/pool/main/x/${pkgname}/${pkgname}_${_major}-${_srcminor}.tar.gz
$pkgname.initd
no_bash_dependency.patch
identify_alpine.patch
fix_cflags.patch
no_hard_links.patch
+ xe-update-guest-attrs_466.patch
"
_builddir="$srcdir"/$pkgname-$_major
@@ -57,4 +59,5 @@ d2eefda7fb55926dddbf87f17989b16e xe-guest-utilities.initd
1fe4c6c4621982a87de97d897612eef7 no_bash_dependency.patch
aa129940379b312783dc314497f62042 identify_alpine.patch
cf32b9c90ce2e846d2221eaca0638929 fix_cflags.patch
-96e872ed89792f9d1b5cb51f8fdfd5f6 no_hard_links.patch"
+96e872ed89792f9d1b5cb51f8fdfd5f6 no_hard_links.patch
+3e104e3dfa4bbf618e4b16ce5a8d502d xe-update-guest-attrs_466.patch"
diff --git a/main/xe-guest-utilities/xe-update-guest-attrs_466.patch b/main/xe-guest-utilities/xe-update-guest-attrs_466.patch
new file mode 100644
index 00000000..c0ef7929
--- /dev/null
+++ b/main/xe-guest-utilities/xe-update-guest-attrs_466.patch
@@ -0,0 +1,32 @@
+--- 458/usr/sbin/xe-update-guest-attrs
++++ 466/usr/sbin/xe-update-guest-attrs
+@@ -82,6 +82,20 @@
+ return 1
+ }
+
++# If we detect a domain change then delete our cache and force a refresh
++domid=$(xenstore-read "domid")
++cache=/var/cache/xenstore/unique-domain-id
++newval=$(xenstore-read "/local/domain/${domid}/unique-domain-id")
++if [ -e $cache ]; then
++ oldval=$(cat "$cache")
++ if [ "$oldval" != "$newval" ]; then
++ # domain changed
++ rm -rf /var/cache/xenstore
++ fi
++fi
++mkdir -p $(dirname "$cache")
++echo -n "$newval" > "$cache"
++
+ xenstore_rm_cached() {
+ key="$1"
+ cache=/var/cache/xenstore/$key
+@@ -195,7 +209,7 @@
+ xenstore_write_cached "attr/PVAddons/MajorVersion" "5"
+ xenstore_write_cached "attr/PVAddons/MinorVersion" "5"
+ xenstore_write_cached "attr/PVAddons/MicroVersion" "0"
+-xenstore_write_cached "attr/PVAddons/BuildVersion" "17913"
++xenstore_write_cached "attr/PVAddons/BuildVersion" "25727"
+ xenstore_write_cached "attr/PVAddons/Installed" "1"
+
+ # update xenstore if necc