summaryrefslogtreecommitdiffstats
path: root/main/gegl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/gegl/APKBUILD')
-rw-r--r--main/gegl/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/main/gegl/APKBUILD b/main/gegl/APKBUILD
new file mode 100644
index 00000000..1db5bd38
--- /dev/null
+++ b/main/gegl/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gegl
+pkgver=0.1.2
+pkgrel=0
+pkgdesc="Graph based image processing framework"
+url="http://www.gegl.org/"
+license="GPL3 LGPL3"
+makedepends="babl-dev libpng-dev jpeg-dev gtk+-dev librsvg-dev lua-dev"
+subpackages="$pkgname-dev"
+source="ftp://ftp.gimp.org/pub/$pkgname/0.1/$pkgname-$pkgver.tar.bz2
+ gegl-uclibc.patch"
+
+depends_dev="babl-dev glib-dev"
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in "$srcdir"/*patch; do
+ patch -p1 -i "$i" || return 1
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --with-librsvg \
+ --disable-docs \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="d35ffe17dc042652eca3205488ece262 gegl-0.1.2.tar.bz2
+e8efbd53553220b97650a3b693461fa5 gegl-uclibc.patch"