summaryrefslogtreecommitdiffstats
path: root/main/libxcursor
diff options
context:
space:
mode:
Diffstat (limited to 'main/libxcursor')
-rw-r--r--main/libxcursor/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/main/libxcursor/APKBUILD b/main/libxcursor/APKBUILD
new file mode 100644
index 00000000..bc9e33d4
--- /dev/null
+++ b/main/libxcursor/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libxcursor
+pkgver=1.1.10
+pkgrel=1
+pkgdesc="X cursor management library"
+url="http://xorg.freedesktop.org/"
+license="custom"
+subpackages="$pkgname-dev $pkgname-doc"
+depends=
+makedepends="pkgconfig libxfixes-dev libx11-dev libxrender-dev"
+source="http://xorg.freedesktop.org/releases/individual/lib/libXcursor-$pkgver.tar.bz2"
+
+depends_dev="xproto libx11-dev libxrender-dev libxfixes-dev"
+build() {
+ cd "$srcdir"/libXcursor-$pkgver
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/libXcursor-$pkgver
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="7dcdad1c10daea872cb3355af414b2ca libXcursor-1.1.10.tar.bz2"