summaryrefslogtreecommitdiffstats
path: root/main/linux-grsec/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/linux-grsec/APKBUILD')
-rw-r--r--main/linux-grsec/APKBUILD25
1 files changed, 12 insertions, 13 deletions
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index 759d6716..538324b8 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -2,9 +2,9 @@
_flavor=grsec
pkgname=linux-${_flavor}
-pkgver=2.6.32.11
+pkgver=2.6.32.14
_kernver=2.6.32
-pkgrel=2
+pkgrel=0
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
depends="mkinitfs linux-firmware"
@@ -14,15 +14,12 @@ _config=${config:-kernelconfig.${CARCH:-x86}}
install=
source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-$pkgver.bz2
- grsecurity-2.1.14-2.6.32.11-201004071936.patch
+ grsecurity-2.1.14-2.6.32.14-201005291720.patch
0001-grsec-revert-conflicting-flow-cache-changes.patch
0002-gre-fix-hard-header-destination-address-checking.patch
0003-ip_gre-include-route-header_len-in-max_headroom-calc.patch
0004-arp-flush-arp-cache-on-device-change.patch
- 0005-r8169-fix-broken-register-writes.patch
- 0006-r8169-offical-fix-for-CVE-2009-4537-overlength-frame.patch
0007-r8169-Fix-rtl8169_rx_interrupt.patch
- 0008-r8169-clean-up-my-printk-uglyness.patch
0009-ipsec-Fix-bogus-bundle-flowi.patch
0010-xfrm-Remove-xfrm_state_genid.patch
0011-xfrm_user-verify-policy-direction-at-XFRM_MSG_POLEXP.patch
@@ -33,6 +30,7 @@ source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
0016-xfrm-remove-policy-garbage-collection.patch
0017-flow-delayed-deletion-of-flow-cache-entries.patch
0018-xfrm-Fix-crashes-in-xfrm_lookup.patch
+ xfrm-fix-policy-unreferencing-on-larval-drop.patch
kernelconfig.x86
"
subpackages="$pkgname-dev linux-firmware:firmware"
@@ -47,7 +45,8 @@ prepare() {
fi
# first apply the grsecurity patch and then the rest
- for i in "$srcdir"/grsecurity*.patch "$srcdir"/0[0-9]*.patch; do
+ for i in "$srcdir"/grsecurity*.patch "$srcdir"/0[0-9]*.patch \
+ "$srcdir"/xfrm*; do
[ -f $i ] || continue
msg "Applying $i..."
patch -s -p1 -N < $i || return 1
@@ -68,7 +67,9 @@ menuconfig() {
build() {
cd "$srcdir"/build
- make CC="${CC:--gcc}" || return 1
+ make CC="${CC:--gcc}" \
+ KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-Alpine" \
+ || return 1
}
package() {
@@ -138,16 +139,13 @@ firmware() {
}
md5sums="260551284ac224c3a43c4adac7df4879 linux-2.6.32.tar.bz2
-855c248334a71ef5ca3d8cb89d51334f patch-2.6.32.11.bz2
-6eabb0c08a988a97a823b5462d1c5018 grsecurity-2.1.14-2.6.32.11-201004071936.patch
+90f0ec928aff643f05a8b98fad54b10c patch-2.6.32.14.bz2
+a9985ec4cf7a50beaa755b1ebde839c4 grsecurity-2.1.14-2.6.32.14-201005291720.patch
1d247140abec49b96250aec9aa59b324 0001-grsec-revert-conflicting-flow-cache-changes.patch
437317f88ec13ace8d39c31983a41696 0002-gre-fix-hard-header-destination-address-checking.patch
151b29a161178ed39d62a08f21f3484d 0003-ip_gre-include-route-header_len-in-max_headroom-calc.patch
776adeeb5272093574f8836c5037dd7d 0004-arp-flush-arp-cache-on-device-change.patch
-afa06334c81f21c20571286a83d3d928 0005-r8169-fix-broken-register-writes.patch
-c538c0f735d79fd71b47dde02bf1f790 0006-r8169-offical-fix-for-CVE-2009-4537-overlength-frame.patch
5f8b9a76d95319c5b1aa26b54a42e6b5 0007-r8169-Fix-rtl8169_rx_interrupt.patch
-f878c802700e3babd03be3505119c5c2 0008-r8169-clean-up-my-printk-uglyness.patch
cf168620efa63479a6e03da78906e32f 0009-ipsec-Fix-bogus-bundle-flowi.patch
3af4b5ae1afae3278b0070f585b874e3 0010-xfrm-Remove-xfrm_state_genid.patch
9f284c3fd5ab38cef4544efc1f50c6ba 0011-xfrm_user-verify-policy-direction-at-XFRM_MSG_POLEXP.patch
@@ -158,4 +156,5 @@ c09b82b89a49ba2a3836a0bc3a3312f4 0015-xfrm-cache-bundles-instead-of-policies-fo
41618efb65ab9ddacfb59a1cde9b4edd 0016-xfrm-remove-policy-garbage-collection.patch
3b83f0972ab715819d1119b120a987e7 0017-flow-delayed-deletion-of-flow-cache-entries.patch
45a676c7a1759fec60b724d557b4e295 0018-xfrm-Fix-crashes-in-xfrm_lookup.patch
+c7e606c11c05ff03012b21c3fe0ece47 xfrm-fix-policy-unreferencing-on-larval-drop.patch
7f442049b29ab749180e54ff8f20f1d0 kernelconfig.x86"