summaryrefslogtreecommitdiffstats
path: root/main/lua-pc
diff options
context:
space:
mode:
Diffstat (limited to 'main/lua-pc')
-rw-r--r--main/lua-pc/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/main/lua-pc/APKBUILD b/main/lua-pc/APKBUILD
new file mode 100644
index 00000000..85643205
--- /dev/null
+++ b/main/lua-pc/APKBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua-pc
+_name=lpc
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Lua Process Call"
+url="http://lua.net-core.org/sputnik.lua?p=Telesto:About"
+license="MIT/X11"
+makedepends="lua-dev"
+depends="lua"
+source="http://lua.net-core.org/dl/telesto/lpc-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ make CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS -shared"
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ # does not respect DESTDIR
+ make install PREFIX="$pkgdir"/usr
+}
+
+md5sums="d1516818de2d94ea0c9d748726cf0d72 lpc-1.0.0.tar.gz"