summaryrefslogtreecommitdiffstats
path: root/main/perl-file-rsync/perl-file-rsync-parallell-build-fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-file-rsync/perl-file-rsync-parallell-build-fix.patch')
-rw-r--r--main/perl-file-rsync/perl-file-rsync-parallell-build-fix.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/main/perl-file-rsync/perl-file-rsync-parallell-build-fix.patch b/main/perl-file-rsync/perl-file-rsync-parallell-build-fix.patch
new file mode 100644
index 00000000..d9316f3d
--- /dev/null
+++ b/main/perl-file-rsync/perl-file-rsync-parallell-build-fix.patch
@@ -0,0 +1,20 @@
+diff --git a/FileList/Makefile.PL b/FileList/Makefile.PL
+index 2061b0a..3ab345f 100644
+--- a/FileList/Makefile.PL
++++ b/FileList/Makefile.PL
+@@ -16,7 +16,14 @@ WriteMakefile(
+ snprintf$(OBJ_EXT)
+ wildmatch$(OBJ_EXT)
+ ],
+- 'depend' => { 'FileList.o' => 'config.h' },
++ 'depend' => { 'FileList$(OBJ_EXT)' => 'config.h',
++ 'exclude$(OBJ_EXT)' => 'config.h',
++ 'flist$(OBJ_EXT)' => 'config.h',
++ 'hlink$(OBJ_EXT)' => 'config.h',
++ 'pool_alloc$(OBJ_EXT)' => 'config.h',
++ 'snprintf$(OBJ_EXT)' => 'config.h',
++ 'wildmatch$(OBJ_EXT)' => 'config.h',
++ },
+ 'clean' => {FILES => "configure.in config.log config.status config.h conftest* confdefs*"},
+ );
+