summaryrefslogtreecommitdiffstats
path: root/main/tftpd-hpa/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/tftpd-hpa/APKBUILD')
-rw-r--r--main/tftpd-hpa/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/main/tftpd-hpa/APKBUILD b/main/tftpd-hpa/APKBUILD
new file mode 100644
index 00000000..c507e2f6
--- /dev/null
+++ b/main/tftpd-hpa/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=tftp-hpa
+pkgver=5.0
+pkgrel=0
+pkgdesc="Official tftp server"
+url="http://www.kernel.org/pub/software/network/tftp/"
+license="BSD"
+depends=
+makedepends=
+subpackage="$pkgname-doc"
+source="http://www.kernel.org/pub/software/network/tftp/$pkgname-$pkgver.tar.gz
+ in.tftpd.initd
+ in.tftpd.confd
+ "
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man || return 1
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make INSTALLROOT="$pkgdir" install || return 1
+ install -d "$pkgdir"/var/tftpboot
+ install -Dm755 ../in.tftpd.initd "$pkgdir"/etc/init.d/in.tftpd
+ install -Dm755 ../in.tftpd.confd "$pkgdir"/etc/conf.d/in.tftpd
+}
+md5sums="1ae813a94670f0d8c294aafa9f5ecf65 tftp-hpa-5.0.tar.gz
+3430e0b0e42c3321689d2c87e73d0749 in.tftpd.initd
+914b43dd531176a8bb58fdb23d900fef in.tftpd.confd"