summaryrefslogtreecommitdiffstats
path: root/main/v86d/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/v86d/APKBUILD')
-rw-r--r--main/v86d/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/main/v86d/APKBUILD b/main/v86d/APKBUILD
index 8bcdcf61..95f72699 100644
--- a/main/v86d/APKBUILD
+++ b/main/v86d/APKBUILD
@@ -1,10 +1,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=v86d
pkgver=0.1.9
+pkgrel=1
pkgdesc="userspace helper for uvesafb that runs x86 code in an emulated environment"
url="http://dev.gentoo.org/~spock/projects/uvesafb/"
license="GPL2"
-depends="uclibc"
+depends=""
makedepends="bash"
source="http://dev.gentoo.org/~spock/projects/uvesafb/archive/$pkgname-$pkgver.tar.bz2
modprobe.uvesafb"
@@ -14,6 +15,10 @@ build ()
cd "$srcdir"/v86d-$pkgver
./configure --with-x86emu
make || return 1
+}
+
+package() {
+ cd "$srcdir"/v86d-$pkgver
make DESTDIR="$pkgdir" install || return 1
install -D -m644 "$srcdir"/modprobe.uvesafb "$pkgdir"/etc/modprobe.d/uvesafb || return 1
}