summaryrefslogtreecommitdiffstats
path: root/main/xchat/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/xchat/APKBUILD')
-rw-r--r--main/xchat/APKBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/main/xchat/APKBUILD b/main/xchat/APKBUILD
index cb4bdbef..c5c67a59 100644
--- a/main/xchat/APKBUILD
+++ b/main/xchat/APKBUILD
@@ -1,23 +1,23 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xchat
-pkgver=2.8.6
-pkgrel=2
+pkgver=2.8.8
+pkgrel=0
pkgdesc="A GTK+ based IRC client"
url="http://www.xchat.org/"
license="GPL"
makedepends="pkgconfig gtk+-dev openssl-dev dbus-glib-dev perl-dev
libxext-dev"
source="http://www.$pkgname.org/files/source/2.8/$pkgname-$pkgver.tar.bz2
- http://www.$pkgname.org/files/source/2.8/patches/xc286-smallfixes.diff
- depreciated-macros.patch
- $pkgname-gtk2.patch"
+ "
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
- patch -p1 < ../xc286-smallfixes.diff || return 1
- patch -p1 -i "$srcdir"/depreciated-macros.patch || return 1
- patch -p1 < ../xchat-gtk2.patch || return 1
+ for i in "$srcdir"/*.patch; do
+ [ -r "$i" ] || continue
+ msg "Applying $i"
+ patch -p1 -i "$i" || return 1
+ done
}
@@ -42,7 +42,4 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="1f2670865d43a23a9abc596dde999aca xchat-2.8.6.tar.bz2
-eb68b6261bf6740cb5f223627eb8f384 xc286-smallfixes.diff
-daee42354f95ca54a84248c3cb690fee depreciated-macros.patch
-f3fe00982c0bec93152ed0b32438ef87 xchat-gtk2.patch"
+md5sums="6775c44f38e84d06c06c336b32c4a452 xchat-2.8.8.tar.bz2"