summaryrefslogtreecommitdiffstats
path: root/testing/asterisk-audio-konf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/asterisk-audio-konf/APKBUILD')
-rw-r--r--testing/asterisk-audio-konf/APKBUILD66
1 files changed, 66 insertions, 0 deletions
diff --git a/testing/asterisk-audio-konf/APKBUILD b/testing/asterisk-audio-konf/APKBUILD
new file mode 100644
index 00000000..d10dcbc9
--- /dev/null
+++ b/testing/asterisk-audio-konf/APKBUILD
@@ -0,0 +1,66 @@
+# Contributor:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=asterisk-audio-konf
+_basever=0
+_gitver=100527
+pkgver=${_basever}_git${_gitver}
+pkgrel=0
+pkgdesc="A fork of AppKonference focused entirely on audio conferencing"
+url="http://github.com/jthomerson/AsteriskAudioKonf/"
+license="GPL"
+depends=
+makedepends="asterisk-dev"
+install=
+subpackages=
+_snapfile="$pkgname-$pkgver.tar.bz2"
+source="http://build.alpinelinux.org:8010/distfiles/$_snapfile
+ 0001-create-install-dir.patch
+ "
+
+_gitver=100527
+_giturl="git://github.com/jthomerson/AsteriskAudioKonf.git"
+
+
+_builddir="$srcdir"/$pkgname/konference
+
+
+snapshot() {
+ _gitver=$(date +%y%m%d)
+ pkgver=${_basever}_git$_gitver
+
+ if [ -d "$SRCDEST"/$pkgname ]; then
+ cd "$SRCDEST"/$pkgname
+ git pull --rebase || return 1
+ else
+ cd "$SRCDEST"
+ git clone $_giturl $pkgname
+ fi
+ cd "$SRCDEST"
+ tar -jcf $_snapfile $pkgname
+
+ pkgrel=0
+ sed -i -e "s/^_gitver=.*/_gitver=${_gitver}/" \
+ -e "s/^pkgrel=.*/pkgrel=$pkgrel/" \
+ "$startdir"/APKBUILD
+ checksum
+}
+
+prepare() {
+ cd "$_builddir"/..
+ for i in "$srcdir"/*.patch; do
+ patch -p1 -i "$i" || return 1
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make INSTALL_PREFIX="$pkgdir" install
+}
+
+md5sums="4e81c731d4b4bd258cd426b5d5dfcdc0 asterisk-audio-konf-0_git100527.tar.bz2
+822df062f4f0890889e3be382ae90504 0001-create-install-dir.patch"