summaryrefslogtreecommitdiffstats
path: root/testing/atop/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/atop/APKBUILD')
-rw-r--r--testing/atop/APKBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/testing/atop/APKBUILD b/testing/atop/APKBUILD
index 74aec10c..ecbfb102 100644
--- a/testing/atop/APKBUILD
+++ b/testing/atop/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=atop
pkgver=1.24
-pkgrel=0
+pkgrel=1
pkgdesc="Resource-specific view of processes"
url="http://www.atcomputing.nl/Tools/atop"
license="GPL-2"
@@ -9,14 +9,15 @@ depends=
makedepends="zlib-dev ncurses-dev"
subpackages="$pkgname-doc"
source="http://www.atoptool.nl/packages/atop-$pkgver.tar.gz
+ atop-bb-compat.patch
atop.initd"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
+ patch -p1 -i "$srcdir"/atop-bb-compat.patch || return 1
sed -i -e '/^CFLAGS/s: = -O : += :' \
-e '/^LDFLAGS/s: = : += :' Makefile
- sed -i -e 's:bash:sh:' atop.daily
cp "$srcdir"/atop.initd atop.init
chmod a+rx atop.init
}
@@ -40,4 +41,5 @@ package() {
}
md5sums="46522f7da28460e810e193ab46907af9 atop-1.24.tar.gz
+a4119e314cdc6d50bf027add32e1902b atop-bb-compat.patch
06aba14ddeadbb1d0c3594536785213b atop.initd"