summaryrefslogtreecommitdiffstats
path: root/testing/hdparm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/hdparm/APKBUILD')
-rw-r--r--testing/hdparm/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/hdparm/APKBUILD b/testing/hdparm/APKBUILD
new file mode 100644
index 00000000..f9fb4bf9
--- /dev/null
+++ b/testing/hdparm/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=hdparm
+pkgver=9.27
+pkgrel=1
+pkgdesc="A shell utility for manipulating Linux IDE drive/driver parameters"
+url="http://sourceforge.net/projects/hdparm/"
+license="BSD"
+depends=
+makedepends=
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz
+ hdparm.initd
+ hdparm.confd"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr "$pkgdir"/sbin
+ make DESTDIR="$pkgdir" install || return 1
+ install -m755 contrib/idectl "$pkgdir"/sbin || return 1
+ install -m755 contrib/ultrabayd "$pkgdir"/sbin || return 1
+ install -Dm755 "$srcdir"/hdparm.initd "$pkgdir"/etc/init.d/hdparm
+ install -Dm644 "$srcdir"/hdparm.confd "$pkgdir"/etc/conf.d/hdparm
+ install -D -m 644 LICENSE.TXT $pkgdir/usr/share/licenses/hdparm/LICENSE.TXT || return 1
+}
+md5sums="e652dabb6c9233fb8a23ef60a17a1829 hdparm-9.27.tar.gz
+d530139a31b3941b3b0fbb4d98391a85 hdparm.initd
+998430f701b1d54588cb02ef1505c3ed hdparm.confd"