summaryrefslogtreecommitdiffstats
path: root/testing/icecast/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/icecast/APKBUILD')
-rw-r--r--testing/icecast/APKBUILD16
1 files changed, 14 insertions, 2 deletions
diff --git a/testing/icecast/APKBUILD b/testing/icecast/APKBUILD
index 73135371..0e7c70e7 100644
--- a/testing/icecast/APKBUILD
+++ b/testing/icecast/APKBUILD
@@ -2,20 +2,30 @@
# Maintainer:
pkgname=icecast
pkgver=2.3.2
-pkgrel=0
+pkgrel=1
pkgdesc="Open source media server"
url="http://www.icecast.org"
license="GPL"
depends=
+install="$pkgname.pre-install"
+pkgusers="icecast"
+pkggroups="icecast"
makedepends="libxslt-dev libxml2-dev libogg-dev libvorbis-dev libtheora-dev"
subpackages="$pkgname-doc"
source="http://downloads.xiph.org/releases/$pkgname/$pkgname-$pkgver.tar.gz
+ conf-change-owner.patch
icecast.initd"
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+ patch -p1 -i "$srcdir"/conf-change-owner.patch
+}
+
build() {
cd "$srcdir"/$pkgname-$pkgver
./configure --prefix=/usr \
+ --localstatedir=/var \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info
@@ -26,7 +36,9 @@ package() {
cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install
install -D -m755 ../icecast.initd "$pkgdir"/etc/init.d/icecast
+ install -d -D -o icecast -g icecast "$pkgdir"/var/log/icecast
}
md5sums="ff516b3ccd2bcc31e68f460cd316093f icecast-2.3.2.tar.gz
-b6f2fc5eaada6e9389784ccf43f68684 icecast.initd"
+d65fe756a3811e21fd8327ec599206c8 conf-change-owner.patch
+0dc8432dbd5cba6a5ace22028adfe287 icecast.initd"