summaryrefslogtreecommitdiffstats
path: root/testing/icecast
diff options
context:
space:
mode:
Diffstat (limited to 'testing/icecast')
-rw-r--r--testing/icecast/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/icecast/APKBUILD b/testing/icecast/APKBUILD
new file mode 100644
index 00000000..b9d34f42
--- /dev/null
+++ b/testing/icecast/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor:
+# Maintainer:
+pkgname=icecast
+pkgver=2.3.2
+pkgrel=0
+pkgdesc="Open source media server"
+url="http://www.icecast.org"
+license="GPL"
+depends="busybox"
+makedepends="libxslt-dev libxml2-dev libogg-dev libvorbis-dev libtheora-dev"
+subpackages="$pkgname-doc"
+source="http://downloads.xiph.org/releases/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="ff516b3ccd2bcc31e68f460cd316093f icecast-2.3.2.tar.gz"