summaryrefslogtreecommitdiffstats
path: root/testing/iscsi-scst-svn/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/iscsi-scst-svn/APKBUILD')
-rw-r--r--testing/iscsi-scst-svn/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/iscsi-scst-svn/APKBUILD b/testing/iscsi-scst-svn/APKBUILD
new file mode 100644
index 00000000..f322407e
--- /dev/null
+++ b/testing/iscsi-scst-svn/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Carlo Landmeter
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+
+pkgname=iscsi-scst-svn
+pkgver=1713
+pkgrel=0
+pkgdesc="ISCSI target for SCST - userspace tools"
+url="http://iscsi-scst.sourceforge.net/"
+license="GPL-2"
+depends=
+install=
+makedepends="openssl-dev scst-svn-scst-dev bash"
+subpackages=
+source="http://alpine.nethq.org/clandmeter/src/$pkgname-$pkgver.tar.gz
+ iscsi-scst.initd
+ "
+
+_builddir="$srcdir"/iscsi-scst
+prepare() {
+ cd "$_builddir"
+ # we need the headre file. fix dependency in makefile
+ sed -i -e 's/^\(progs:.*\)/\1 include\/iscsi_scst_itf_ver.h/' Makefile
+}
+
+build() {
+ cd "$_builddir"
+ make progs \
+ SCST_INC_DIR=/usr/include/scst
+}
+
+package() {
+ cd "$_builddir"
+ # make install is broken
+ install -D usr/iscsi-scstd "$pkgdir"/usr/sbin/iscsi-scstd
+ install -D usr/iscsi-scst-adm "$pkgdir"/usr/sbin/iscsi-scst-adm
+ install -D -m 755 "$srcdir"/iscsi-scst.initd "$pkgdir"/etc/init.d/iscsi-scst
+}
+
+md5sums="cf046db4f7cd9cf969b054dc055922d6 iscsi-scst-svn-1713.tar.gz
+3132fae1ec2f9bcc72476d9e9f36d326 iscsi-scst.initd"