summaryrefslogtreecommitdiffstats
path: root/testing/iscsi-scst/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/iscsi-scst/APKBUILD')
-rw-r--r--testing/iscsi-scst/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/iscsi-scst/APKBUILD b/testing/iscsi-scst/APKBUILD
new file mode 100644
index 00000000..1624175d
--- /dev/null
+++ b/testing/iscsi-scst/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Carlo Landmeter
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+
+pkgname=iscsi-scst
+pkgver=1.0.1.1
+pkgrel=2
+pkgdesc="ISCSI target for SCST - userspace tools"
+url="http://iscsi-scst.sourceforge.net/"
+license="GPL-2"
+depends=
+install=
+makedepends="openssl-dev"
+subpackages=
+source="http://downloads.sourceforge.net/scst/$pkgname-$pkgver.tar.gz
+ iscsi-scst.initd
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ # we need the headre file. fix dependency in makefile
+ sed -i -e 's/^\(progs:.*\)/\1 include\/iscsi_scst_itf_ver.h/' Makefile
+}
+
+build() {
+ cd "$_builddir"
+ make progs
+}
+
+package() {
+ cd "$_builddir"
+ # make install is broken
+ install -D usr/iscsi-scstd "$pkgdir"/usr/sbin/iscsi-scstd
+ install -D usr/iscsi-scst-adm "$pkgdir"/iscsi-scst-adm
+ install -D -m 755 "$srcdir"/iscsi-scst.initd "$pkgdir"/etc/init.d/iscsi-scst
+}
+
+md5sums="56109c01e3d4421a36d6f47efa1fb0d5 iscsi-scst-1.0.1.1.tar.gz
+3132fae1ec2f9bcc72476d9e9f36d326 iscsi-scst.initd"