summaryrefslogtreecommitdiffstats
path: root/testing/libical/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libical/APKBUILD')
-rw-r--r--testing/libical/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/libical/APKBUILD b/testing/libical/APKBUILD
new file mode 100644
index 00000000..22ef9678
--- /dev/null
+++ b/testing/libical/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libical
+pkgver=0.44
+pkgrel=0
+pkgdesc="An open source reference implementation of the icalendar data type and serialization format"
+url="http://sourceforge.net/projects/freeassociation/"
+license="LGPL MPL"
+depends=
+makedepends="perl"
+subpackages="$pkgname-dev"
+source="http://downloads.sourceforge.net/freeassociation/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --enable-shared \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+md5sums="e0403c31e1ed82569325685f8c15959c libical-0.44.tar.gz"