summaryrefslogtreecommitdiffstats
path: root/testing/linux-grsec/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/linux-grsec/APKBUILD')
-rw-r--r--testing/linux-grsec/APKBUILD138
1 files changed, 138 insertions, 0 deletions
diff --git a/testing/linux-grsec/APKBUILD b/testing/linux-grsec/APKBUILD
new file mode 100644
index 00000000..356594fb
--- /dev/null
+++ b/testing/linux-grsec/APKBUILD
@@ -0,0 +1,138 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+
+_flavor=grsec
+pkgname=linux-${_flavor}
+pkgver=2.6.32.8
+_kernver=2.6.32
+pkgrel=2
+pkgdesc="Linux kernel with grsecurity"
+url=http://grsecurity.net
+depends="mkinitfs linux-firmware"
+makedepends="perl installkernel"
+options="!strip"
+_config=${config:-kernelconfig.${CARCH:-x86}}
+install=
+source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
+ ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-$pkgver.bz2
+ grsecurity-2.1.14-2.6.32.8-201002132204.patch
+ 0001-xfrm-introduce-basic-mark-infrastructure.patch
+ 0002-xfrm-SA-lookups-signature-with-mark.patch
+ 0003-xfrm-SA-lookups-with-mark.patch
+ 0004-xfrm-SP-lookups-signature-with-mark.patch
+ 0005-xfrm-SP-lookups-with-mark.patch
+ 0006-xfrm-Allow-user-space-config-of-SAD-mark.patch
+ 0007-xfrm-Allow-user-space-manipulation-of-SPD-mark.patch
+ kernelconfig.x86
+ "
+subpackages="$pkgname-dev linux-firmware:firmware"
+license="GPL-2"
+
+_abi_release=${pkgver}-${_flavor}
+
+prepare() {
+ cd "$srcdir"/linux-$_kernver
+ if [ "$_kernver" != "$pkgver" ]; then
+ bunzip2 -c < ../patch-$pkgver.bz2 | patch -p1 -N || return 1
+ fi
+
+ for i in ../*.diff ../*.patch; do
+ [ -f $i ] || continue
+ msg "Applying $i..."
+ patch -s -p1 -N < $i || return 1
+ done
+
+ mkdir -p "$srcdir"/build
+ cp "$srcdir"/$_config "$srcdir"/build/.config
+ make -C "$srcdir"/linux-$_kernver O="$srcdir"/build HOSTCC="$CC" \
+ silentoldconfig
+}
+
+# this is so we can do: 'abuild menuconfig' to reconfigure kernel
+menuconfig() {
+ cd "$srcdir"/build || return 1
+ make menuconfig
+ cp .config "$startdir"/$_config
+}
+
+build() {
+ cd "$srcdir"/build
+ make CC="$CC" || return 1
+}
+
+package() {
+ cd "$srcdir"/build
+ mkdir -p "$pkgdir"/boot "$pkgdir"/lib/modules
+ make modules_install install \
+ INSTALL_MOD_PATH="$pkgdir" \
+ INSTALL_PATH="$pkgdir"/boot
+
+ rm -f "$pkgdir"/lib/modules/${_abi_release}/build \
+ "$pkgdir"/lib/modules/${_abi_release}/source
+ install -D include/config/kernel.release \
+ "$pkgdir"/usr/share/kernel/$_flavor/kernel.release
+}
+
+dev() {
+ # copy the only the parts that we really need for build 3rd party
+ # kernel modules and install those as /usr/src/linux-headers,
+ # simlar to what ubuntu does
+ #
+ # this way you dont need to install the 300-400 kernel sources to
+ # build a tiny kernel module
+ #
+ pkgdesc="Headers and script for third party modules for grsec kernel"
+ local dir="$subpkgdir"/usr/src/linux-headers-${_abi_release}
+
+ # first we import config, run prepare to set up for building
+ # external modules, and create the scripts
+ mkdir -p "$dir"
+ cp "$srcdir"/$_config "$dir"/.config
+ make -j1 -C "$srcdir"/linux-$_kernver O="$dir" HOSTCC="$CC" \
+ silentoldconfig prepare scripts
+
+ # remove the stuff that poits to real sources. we want 3rd party
+ # modules to believe this is the soruces
+ rm "$dir"/Makefile "$dir"/source
+
+ # copy the needed stuff from real sources
+ #
+ # this is taken from ubuntu kernel build script
+ # http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-jaunty.git;a=blob;f=debian/rules.d/3-binary-indep.mk;hb=HEAD
+ cd "$srcdir"/linux-$_kernver
+ find . -path './include/*' -prune -o -path './scripts/*' -prune \
+ -o -type f \( -name 'Makefile*' -o -name 'Kconfig*' \
+ -o -name 'Kbuild*' -o -name '*.sh' -o -name '*.pl' \
+ -o -name '*.lds' \) | cpio -pdm "$dir"
+ cp -a drivers/media/dvb/dvb-core/*.h "$dir"/drivers/media/dvb/dvb-core
+ cp -a drivers/media/video/*.h "$dir"/drivers/media/video
+ cp -a drivers/media/dvb/frontends/*.h "$dir"/drivers/media/dvb/frontends
+ cp -a scripts include "$dir"
+ find $(find arch -name include -type d -print) -type f \
+ | cpio -pdm "$dir"
+
+ install -Dm644 "$srcdir"/build/Module.symvers \
+ "$dir"/Module.symvers
+
+ mkdir -p "$subpkgdir"/lib/modules/${_abi_release}
+ ln -sf /usr/src/linux-headers-${_abi_release} \
+ "$subpkgdir"/lib/modules/${_abi_release}/build
+}
+
+firmware() {
+ pkgdesc="Firmware for linux kernel"
+ replaces="linux-grsec linux-vserver"
+ mkdir -p "$subpkgdir"/lib
+ mv "$pkgdir"/lib/firmware "$subpkgdir"/lib/
+}
+
+md5sums="260551284ac224c3a43c4adac7df4879 linux-2.6.32.tar.bz2
+eabf01da4c72f7ea5b4e4bf8e8535e5f patch-2.6.32.8.bz2
+005313c701b97f37bb3f49977ec0d596 grsecurity-2.1.14-2.6.32.8-201002132204.patch
+daffc009bd7807f85c695d3eeaf8e09a 0001-xfrm-introduce-basic-mark-infrastructure.patch
+5d9d8d414e81194e3b05d7ef49d78ce3 0002-xfrm-SA-lookups-signature-with-mark.patch
+5767e1fd8648b03be5c03a47ee56fd2f 0003-xfrm-SA-lookups-with-mark.patch
+173b93331ac458bf0aa7a132bc39d8b6 0004-xfrm-SP-lookups-signature-with-mark.patch
+b5c7438b2d876e78a5d9e7a8971cba55 0005-xfrm-SP-lookups-with-mark.patch
+0f8857454aee0eac2ac1024ac4d2ee3b 0006-xfrm-Allow-user-space-config-of-SAD-mark.patch
+facba45fbfedc07ebb7f67cd275e351c 0007-xfrm-Allow-user-space-manipulation-of-SPD-mark.patch
+281d56ac34b2903456df769fd42d81f2 kernelconfig.x86"