summaryrefslogtreecommitdiffstats
path: root/testing/mysql/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mysql/APKBUILD')
-rw-r--r--testing/mysql/APKBUILD53
1 files changed, 0 insertions, 53 deletions
diff --git a/testing/mysql/APKBUILD b/testing/mysql/APKBUILD
deleted file mode 100644
index b828e9c1..00000000
--- a/testing/mysql/APKBUILD
+++ /dev/null
@@ -1,53 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-pkgname=mysql
-pkgver=5.0.75
-pkgrel=4
-pkgdesc="A fast SQL database server"
-url="http://www.mysql.com/"
-license='GPL'
-depends="readline openssl uclibc++"
-makedepends="libtool uclibc++-dev readline-dev openssl-dev"
-source="http://sunsite.informatik.rwth-aachen.de/mysql/Downloads/MySQL-5.0/${pkgname}-${pkgver}.tar.gz
-$pkgname.initd
-$pkgname.mycnf"
-subpackages="$pkgname-doc $pkgname-dev $pkgname-test libmysqlclient"
-
-build() {
- cd "$srcdir/$pkgname-$pkgver"
- export CXX=g++-uc
- ./configure --prefix=/usr --libexecdir=/usr/sbin \
- --localstatedir=/var/lib/mysql \
- --disable-assembler --with-pthread \
- --without-raid --without-libwrap \
- --without-pstack --without-docs \
- --without-embedded-server --with-openssl \
- --without-mysqlfs --without-vio \
- --without-bench --without-debug \
- --with-unix-socket-path=/var/run/mysqld/mysqld.sock \
- --with-innodb --mandir=/usr/share/man || return 1
- make || return 1
- make -j1 DESTDIR="$pkgdir/" install
- install -Dm 755 "$startdir"/$pkgname.initd $pkgdir/etc/init.d/$pkgname
- install -Dm 644 "$startdir"/$pkgname.mycnf $pkgdir/etc/mysql/my.cnf
- install -dDo mysql $pkgdir/var/log/mysql
- install -dDo mysql $pkgdir/var/run/mysqld
-
- # we dont want this be pulled in in the make depends resolving but we
- # want it in the binary package dependency so we add it late.
- depends="$depends libmysqlclient"
-}
-
-libmysqlclient() {
- depends="uclibc"
- mkdir -p "$subpkgdir"/usr/lib/mysql
- mv "$pkgdir"/usr/lib/mysql/libmysqlclient.so* "$subpkgdir"/usr/lib/mysql
-}
-
-test() {
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/mysql-test "$subpkgdir"/usr/
-}
-
-md5sums="a234f0a60a7f8c290d9875cba3a2c5a2 mysql-5.0.75.tar.gz
-3ce9827b22d8fbbb29d83a91cbe98ffc mysql.initd
-15a7e3ddd6a40bf5a1eb3a8c69d9c34c mysql.mycnf"