summaryrefslogtreecommitdiffstats
path: root/testing/py-crypto/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-crypto/APKBUILD')
-rw-r--r--testing/py-crypto/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/py-crypto/APKBUILD b/testing/py-crypto/APKBUILD
new file mode 100644
index 00000000..75f31dd6
--- /dev/null
+++ b/testing/py-crypto/APKBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py-crypto
+pkgver=2.0.1
+pkgrel=2
+pkgdesc="A collection of cryptographic algorithms and protocols, implemented for use from Python."
+url="http://www.amk.ca/python/code/crypto.html"
+license="GPL"
+depends="python"
+makedepends="gmp5-dev python-dev"
+source="http://www.amk.ca/files/python/crypto/pycrypto-$pkgver.tar.gz"
+
+_builddir="$srcdir"/pycrypto-$pkgver
+build ()
+{
+ cd "$_builddir"
+ python setup.py build
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root="$pkgdir"
+}
+md5sums="4d5674f3898a573691ffb335e8d749cd pycrypto-2.0.1.tar.gz"