summaryrefslogtreecommitdiffstats
path: root/testing/py-twisted/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-twisted/APKBUILD')
-rw-r--r--testing/py-twisted/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/testing/py-twisted/APKBUILD b/testing/py-twisted/APKBUILD
new file mode 100644
index 00000000..04e8812c
--- /dev/null
+++ b/testing/py-twisted/APKBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py-twisted
+pkgver=10.0.0
+pkgrel=0
+pkgdesc="Asynchronous networking framework written in Python."
+url="http://twistedmatrix.com/"
+license="MIT"
+depends="python py-crypto py-zope-interface"
+makedepends="python-dev"
+source="http://tmrc.mit.edu/mirror/twisted/Twisted/${pkgver%.*}/Twisted-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir"/Twisted-$pkgver
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$srcdir"/Twisted-$pkgver
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+md5sums="3b226af1a19b25e3b3e93cc6edf5e284 Twisted-10.0.0.tar.bz2"