summaryrefslogtreecommitdiffstats
path: root/testing/python26-setuptools
diff options
context:
space:
mode:
Diffstat (limited to 'testing/python26-setuptools')
-rw-r--r--testing/python26-setuptools/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/python26-setuptools/APKBUILD b/testing/python26-setuptools/APKBUILD
new file mode 100644
index 00000000..27d956f5
--- /dev/null
+++ b/testing/python26-setuptools/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Andrew Manison <amanison@anselsystems.com>
+# Maintainer:
+pkgname=python26-setuptools
+_pkgname=`echo $pkgname |sed -e 's,^python26-,,'`
+pkgver=0.6c11
+pkgrel=0
+pkgdesc="setuptools is a collection of enhancements to the Python distutils"
+url="http://pypi.python.org/pypi/setuptools"
+license="PSF"
+depends="python"
+makedepends=""
+install=
+subpackages=""
+source="http://pypi.python.org/packages/source/s/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+# append extra dependencies to -dev subpackage
+# remove if not used.
+# depends_dev="somepackage-dev"
+
+build() {
+ cd $srcdir/$_pkgname-$pkgver
+ mkdir -p $pkgdir/usr/lib/python2.6/site-packages
+ python setup.py install --root=$pkgdir
+ echo "/usr/lib/python2.6/site-packages/$_pkgname-$pkgver-py2.6.egg" > $pkgdir/usr/lib/python2.6/site-packages/$_pkgname.pth
+
+ # we don't provide a non-suffixed easy_install
+ echo "Removing non-suffixed easy_install ( $pkgdir/usr/bin/easy_install)"
+ rm $pkgdir/usr/bin/easy_install
+}
+
+md5sums="7df2a529a074f613b509fb44feefe74e setuptools-0.6c11.tar.gz"