summaryrefslogtreecommitdiffstats
path: root/unstable
diff options
context:
space:
mode:
Diffstat (limited to 'unstable')
-rw-r--r--unstable/vlc/APKBUILD90
-rw-r--r--unstable/vlc/uclibc.patch65
-rw-r--r--unstable/wzdftpd-svn/APKBUILD46
-rw-r--r--unstable/wzdftpd-svn/wzdftpd-svn.initd32
4 files changed, 233 insertions, 0 deletions
diff --git a/unstable/vlc/APKBUILD b/unstable/vlc/APKBUILD
new file mode 100644
index 00000000..d28ddf07
--- /dev/null
+++ b/unstable/vlc/APKBUILD
@@ -0,0 +1,90 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=vlc
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="A multi-platform MPEG, VCD/DVD, and DivX player"
+url="http://www.videolan.org/vlc/"
+license="GPL-2"
+subpackages="$pkgname-dev $pkgname-doc"
+#depends="libnotify a52dec fluidsynth zvbi libdvbpsi lirc-utils libdca hal
+# libproxy sdl_image libdvdnav>=4.1.3 lua libxv libv4l libcddb smbclient
+# libmatroska taglib sysfsutils libmpcdec ffmpeg>=0.5 libshout libmad
+# qt fribidi libmpeg2 libmodplug avahi ttf-dejavu"
+depends="ttf-dejavu"
+makedepends="
+ a52dec-dev
+ alsa-lib-dev
+ dbus-dev
+ ffmpeg-dev
+ fribidi-dev
+ gtk+-dev
+ libgcrypt-dev
+ libice-dev
+ libiconv-dev
+ libmad-dev
+ libmpeg2-dev
+ libnotify-dev
+ libogg-dev
+ libsm-dev
+ libx11-dev
+ libxext-dev
+ libxv-dev
+ lua-dev
+ mesa-dev
+ pkgconfig
+ sdl-dev
+ sysfsutils-dev
+ x264-dev
+ "
+source="http://download.videolan.org/pub/videolan/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2
+ uclibc.patch
+ "
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ sed -i -e 's:/usr/share/fonts/truetype/freefont/FreeSerifBold.ttf:/usr/share/fonts/TTF/DejaVuSerif-Bold.ttf:' modules/misc/freetype.c
+
+ patch -p1 < ../uclibc.patch || return 1
+ export CFLAGS="$CFLAGS -D_GNU_SOURCE"
+
+ ./configure --prefix=/usr \
+ --disable-mmx \
+ --disable-nls \
+ --disable-optimizations \
+ --disable-qt4 --disable-skins2 \
+ --disable-rpath \
+ --enable-httpd \
+ --enable-realrtsp \
+ --enable-sout \
+ --enable-vlm \
+ || return 1
+
+# --enable-dvdread \
+# --enable-dvdnav \
+# --enable-qt4 \
+# --enable-faad \
+# --enable-skins2 \
+# --enable-dvb \
+# --enable-v4l \
+# --enable-theora \
+# --enable-flac \
+# --enable-snapshot \
+# --enable-hal \
+# --enable-dbus \
+# --enable-dbus-control \
+# --enable-lirc \
+# --enable-shout \
+# --enable-pvr \
+
+ make || return 1
+ make DESTDIR="$pkgdir"/ install || return 1
+ for res in 16 32 48 128; do
+ install -D -m644 share/vlc${res}x${res}.png \
+ "$pkgdir"/usr/share/icons/hicolor/${res}x${res}/apps/vlc.png || return 1
+ done
+ rm -rf "$pkgdir"/usr/lib/mozilla
+}
+
+md5sums="fc78904ab5fa73f518d8fe4e852e7f67 vlc-1.0.0.tar.bz2
+2a16bf6c14a94f41490872aa189db755 uclibc.patch"
diff --git a/unstable/vlc/uclibc.patch b/unstable/vlc/uclibc.patch
new file mode 100644
index 00000000..f71b189a
--- /dev/null
+++ b/unstable/vlc/uclibc.patch
@@ -0,0 +1,65 @@
+--- a/src/misc/linux_specific.c 2009-07-08 09:29:41.000000000 +0000
++++ b/src/misc/linux_specific.c 2009-07-08 09:30:47.000000000 +0000
+@@ -72,14 +72,14 @@
+ }
+ #endif
+
+-#ifdef __GLIBC__
++#if defined(__GLIBC__) && !defined(__UCLIBC__)
+ # include <gnu/libc-version.h>
+ # include <stdlib.h>
+ #endif
+
+ void system_Init (libvlc_int_t *libvlc, int *argc, const char *argv[])
+ {
+-#ifdef __GLIBC__
++#if defined(__GLIBC__) && !defined(__UCLIBC__)
+ const char *glcv = gnu_get_libc_version ();
+
+ /* gettext in glibc 2.5-2.7 is not thread-safe. LibVLC keeps crashing,
+--- a/src/control/vlm.c 2009-07-09 09:21:55.000000000 +0000
++++ b/src/control/vlm.c 2009-07-09 09:22:24.000000000 +0000
+@@ -21,6 +21,10 @@
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston MA 02110-1301, USA.
+ *****************************************************************************/
+
++#ifdef HAVE_CONFIG_H
++# include "config.h"
++#endif
++
+ #include <vlc/libvlc.h>
+ #include <vlc/libvlc_vlm.h>
+ #include <vlc_es.h>
+--- a/src/misc/mtime.c 2009-07-09 11:57:46.000000000 +0000
++++ b/src/misc/mtime.c 2009-07-09 13:48:16.000000000 +0000
+@@ -78,7 +78,7 @@
+ # define _POSIX_CLOCK_SELECTION (-1)
+ #endif
+
+-# if (_POSIX_CLOCK_SELECTION < 0)
++# if (_POSIX_CLOCK_SELECTION < 0) || defined(__UCLIBC__)
+ /*
+ * We cannot use the monotonic clock is clock selection is not available,
+ * as it would screw vlc_cond_timedwait() completely. Instead, we have to
+--- a/src/misc/threads.c 2009-07-09 13:54:08.000000000 +0000
++++ b/src/misc/threads.c 2009-07-09 13:54:32.000000000 +0000
+@@ -474,7 +474,7 @@
+ /* Fairly outdated POSIX support (that was defined in 2001) */
+ # define _POSIX_CLOCK_SELECTION (-1)
+ # endif
+-# if (_POSIX_CLOCK_SELECTION >= 0)
++# if (_POSIX_CLOCK_SELECTION >= 0) && !defined(__UCLIBC__)
+ /* NOTE: This must be the same clock as the one in mtime.c */
+ pthread_condattr_setclock (&attr, CLOCK_MONOTONIC);
+ # endif
+--- a/modules/stream_filter/decomp.c 2009-07-09 14:10:09.000000000 +0000
++++ b/modules/stream_filter/decomp.c 2009-07-09 14:11:37.000000000 +0000
+@@ -28,7 +28,7 @@
+ #include <vlc_network.h>
+ #include <assert.h>
+ #include <unistd.h>
+-#ifndef _POSIX_SPAWN
++#if !defined(_POSIX_SPAWN) || defined(__UCLIBC__)
+ # define _POSIX_SPAWN (-1)
+ #endif
+ #include <fcntl.h>
diff --git a/unstable/wzdftpd-svn/APKBUILD b/unstable/wzdftpd-svn/APKBUILD
new file mode 100644
index 00000000..b9b46265
--- /dev/null
+++ b/unstable/wzdftpd-svn/APKBUILD
@@ -0,0 +1,46 @@
+# This is an example APKBUILD file. Use this as a start to creating your own,
+# and remove these comments.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Contributor: Your Name <youremail@domain.com>
+pkgname=wzdftpd-svn
+pkgver=2040
+pkgrel=2
+pkgdesc="A portable, modular, small, and efficient FTP server"
+url="http://www.wzdftpd.net"
+license='GPL'
+depends=
+makedepends="cmake mysql-dev sqlite-dev tcl-dev openssl-dev flex"
+source="http://alpine.nethq.org/clandmeter/src/wzdftpd-svn2040.tar.gz
+wzdftpd-svn.initd"
+subpackages="$pkgname-doc"
+
+build() {
+ mkdir "$srcdir/${pkgname}"
+ mv "$srcdir/wzdftpd-src" "$srcdir/${pkgname}/"
+ cd "$srcdir/${pkgname}/"
+ cmake \
+ -D CMAKE_INSTALL_PREFIX:PATH=/usr \
+ -D WITH_DUPECHECK:BOOL=ON \
+ -D WITH_SFV:BOOL=ON \
+ -D BUILD_TESTING:BOOL=OFF \
+ -D WITH_Zeroconf:BOOL=ON \
+ -D TCL_LIBRARY:FILEPATH=/usr/lib/libtcl8.5.so \
+ -D WITH_PAM:BOOL=OFF \
+ -D WITH_PerlDev:BOOL=OFF \
+ -D CONF_INSTALL_PATH:PATH=/etc/wzdftpd \
+ ./wzdftpd-src || return 1
+ make || return 1
+ make DESTDIR="$pkgdir/" install
+ mv $pkgdir/usr/var $pkgdir/
+ sed -i -e 's|usr/var|var|' \
+ -e 's|usr/etc|etc|' \
+ -e 's|usr//etc|etc|' \
+ -e 's|#pid_file|pid_file|' \
+ $pkgdir/etc/wzdftpd/wzd.cfg.sample
+ install -Dm 755 "$startdir"/$pkgname.initd $pkgdir/etc/init.d/wzdftpd
+}
+
+md5sums="4bdb2fcaa4ca316261e9f77380818769 wzdftpd-svn2040.tar.gz
+ae2b7497cc7729bfaf346ba0d3b607d2 wzdftpd-svn.initd"
diff --git a/unstable/wzdftpd-svn/wzdftpd-svn.initd b/unstable/wzdftpd-svn/wzdftpd-svn.initd
new file mode 100644
index 00000000..25f4da6f
--- /dev/null
+++ b/unstable/wzdftpd-svn/wzdftpd-svn.initd
@@ -0,0 +1,32 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+ after firewall
+ use dns
+}
+
+checkconfig() {
+ if [ ! -f /etc/wzdftpd/wzd.cfg ] ; then
+ eerror "No /etc/wzdftpd/wzd.cnf file exists!"
+ return 1
+ fi
+ if [ ! -d /var/run/wzdftpd ] ; then
+ install -dD -o ftp -g ftp /var/run/wzdftpd
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting wzdftpd"
+ /usr/sbin/wzdftpd >/dev/null 2>&1 &
+ eend $?
+}
+
+stop () {
+ ebegin "Stopping wzdftpd"
+ start-stop-daemon --stop --quiet \
+ --pidfile=/var/run/wzdftpd/wzdftpd.pid --retry 20
+ eend $?
+}
+