aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMartin Willi <martin@strongswan.org>2006-05-19 12:10:06 +0000
committerMartin Willi <martin@strongswan.org>2006-05-19 12:10:06 +0000
commitb1e69188ce9d0e63f106eb6a1c5c2c2aa1f85f9c (patch)
treec5f8b5a934e2569cd670b6f448296c7fa7d3dbea /Makefile.am
parentbea98d4dd7b28d9ead64c41bc98b1e28901e9b7f (diff)
downloadstrongswan-b1e69188ce9d0e63f106eb6a1c5c2c2aa1f85f9c.tar.bz2
strongswan-b1e69188ce9d0e63f106eb6a1c5c2c2aa1f85f9c.tar.xz
- re-added doxygen apidoc, buildable with "make apidoc"
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index af437a64d..4114e3f10 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1 +1,12 @@
SUBDIRS = src
+EXTRA_DIST = Doxyfile.in
+CLEANFILES = apidoc Doxyfile
+
+Doxyfile : Doxyfile.in
+ sed \
+ -e "s:\@PACKAGE_VERSION\@:$(PACKAGE_VERSION):" \
+ -e "s:\@PACKAGE_NAME\@:$(PACKAGE_NAME):" \
+ $< > $@
+
+apidoc : Doxyfile
+ doxygen