aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMartin Willi <martin@revosec.ch>2015-04-16 16:50:27 +0200
committerMartin Willi <martin@revosec.ch>2015-04-16 16:50:27 +0200
commitd49330a9a877027d8976a5cafc0b4f0ad0da4ff7 (patch)
treef297ac6cbb25d9fc712dd719954160799e539ec1 /Makefile.am
parent31a171f5c4bf4bd6076bf1542c5660f0690c42ba (diff)
parent882c993b8937303f540605811b0bfd090b4f3ca1 (diff)
downloadstrongswan-d49330a9a877027d8976a5cafc0b4f0ad0da4ff7.tar.bz2
strongswan-d49330a9a877027d8976a5cafc0b4f0ad0da4ff7.tar.xz
Merge branch 'utils-split'
Split up the almighty utils.[ch] to separate files in the utils/utils subfolder. These are not meant to include manually, but bring back some order to all this functionality included through utils.h. Additionally give some love to apidoc generation.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index bea4ba7c0..f9e6452a2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -38,7 +38,9 @@ Doxyfile : Doxyfile.in
$(srcdir)/$@.in > $@
apidoc : Doxyfile
- doxygen
+ @test -d apidoc || doxygen
+ @! find Doxyfile src/ -name '*.h' -o -name '*.md' , -newer apidoc | \
+ grep -q '' || doxygen && touch apidoc
cov-reset-common:
@rm -rf $(top_builddir)/coverage
@@ -75,4 +77,4 @@ clean-local: cov-reset-common
@find $(top_builddir)/src $(top_builddir)/scripts -name "*.gcno" -delete
@rm -rf apidoc
-.PHONY: cov-reset-common cov-reset cov-report coverage
+.PHONY: cov-reset-common cov-reset cov-report coverage apidoc