aboutsummaryrefslogtreecommitdiffstats
path: root/conf/Makefile.am
diff options
context:
space:
mode:
authorTobias Brunner <tobias@strongswan.org>2014-02-13 13:50:12 +0100
committerTobias Brunner <tobias@strongswan.org>2014-02-13 13:53:25 +0100
commit5645ad2976cc6d6cee025162ecd457574d748def (patch)
treee350684a99498b34c26d16324440b2ba81b1c65b /conf/Makefile.am
parentf03441c4dd6c602113cc05698d2622127d34d217 (diff)
downloadstrongswan-5645ad2976cc6d6cee025162ecd457574d748def.tar.bz2
strongswan-5645ad2976cc6d6cee025162ecd457574d748def.tar.xz
conf: Fix installation on FreeBSD
Apparently, the -t option for install is not portable.
Diffstat (limited to 'conf/Makefile.am')
-rw-r--r--conf/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/conf/Makefile.am b/conf/Makefile.am
index 8ce377daf..f0212c132 100644
--- a/conf/Makefile.am
+++ b/conf/Makefile.am
@@ -157,10 +157,10 @@ install-data-local: $(plugins_install_src)
test -e "$(DESTDIR)$(strongswanconfdir)/strongswan.conf" || $(INSTALL) -m 644 $(srcdir)/strongswan.conf $(DESTDIR)$(strongswanconfdir)/strongswan.conf || true
for f in $(options_install_src); do \
name=`basename $$f`; \
- test -f "$(DESTDIR)$(strongswanddir)/$$name" || $(INSTALL) -m 644 -t "$(DESTDIR)$(strongswanddir)" $(srcdir)/$$f || true; \
+ test -f "$(DESTDIR)$(strongswanddir)/$$name" || $(INSTALL) -m 644 "$(srcdir)/$$f" "$(DESTDIR)$(strongswanddir)/$$name" || true; \
done
for f in $(plugins_install_src); do \
name=`basename $$f`; \
if test -f "$$f"; then dir=; else dir="$(srcdir)/"; fi; \
- test -f "$(DESTDIR)$(charonconfdir)/$$name" || $(INSTALL) -m 644 -t "$(DESTDIR)$(charonconfdir)" "$$dir$$f" || true; \
+ test -f "$(DESTDIR)$(charonconfdir)/$$name" || $(INSTALL) -m 644 "$$dir$$f" "$(DESTDIR)$(charonconfdir)/$$name" || true; \
done