aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTobias Brunner <tobias@strongswan.org>2015-06-11 12:19:56 +0200
committerTobias Brunner <tobias@strongswan.org>2015-08-17 11:19:44 +0200
commitf25f4192c7ea7f3ccb6759dc000a3272e9c4e815 (patch)
treedc04a23bec7a325e79585fda1235ceae2cd341fd /configure.ac
parentb410d7f8ff39001a3fefa5bebd08de3c295f5c9c (diff)
downloadstrongswan-f25f4192c7ea7f3ccb6759dc000a3272e9c4e815.tar.bz2
strongswan-f25f4192c7ea7f3ccb6759dc000a3272e9c4e815.tar.xz
utils: Directly use syscall() to close open FDs in closefrom()
This avoids any allocations, since calling malloc() after fork() is potentially unsafe. Fixes #990.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index be296fbcc..18132757c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -591,7 +591,7 @@ AC_CHECK_FUNC([syslog], [
])
AM_CONDITIONAL(USE_SYSLOG, [test "x$syslog" = xtrue])
-AC_CHECK_HEADERS(sys/sockio.h glob.h net/if_tun.h)
+AC_CHECK_HEADERS(sys/sockio.h sys/syscall.h glob.h net/if_tun.h)
AC_CHECK_HEADERS(net/pfkeyv2.h netipsec/ipsec.h netinet6/ipsec.h linux/udp.h)
AC_CHECK_HEADERS([netinet/ip6.h linux/fib_rules.h], [], [],
[