aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTobias Brunner <tobias@strongswan.org>2009-12-10 11:08:01 +0100
committerTobias Brunner <tobias@strongswan.org>2009-12-23 17:02:26 +0100
commit070ac5b0b79517e5414ddc21c6f46265de2a28a4 (patch)
tree8a57e40e1f1bd9d8d0f1bb628ce0fd86c29f7274 /configure.in
parent866dc0134a27a14b7d85739c221259a832d313b8 (diff)
downloadstrongswan-070ac5b0b79517e5414ddc21c6f46265de2a28a4.tar.bz2
strongswan-070ac5b0b79517e5414ddc21c6f46265de2a28a4.tar.xz
Check if libpthread is required or not.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e02fedbd7..a80a81b95 100644
--- a/configure.in
+++ b/configure.in
@@ -267,6 +267,11 @@ AC_SEARCH_LIBS(clock_gettime, rt, [RTLIB=$LIBS])
AC_CHECK_FUNCS(clock_gettime)
AC_SUBST(RTLIB)
+dnl Android has pthread_* functions in bionic (libc), others need libpthread
+LIBS=""
+AC_SEARCH_LIBS(pthread_create, pthread, [PTHREADLIB=$LIBS])
+AC_SUBST(PTHREADLIB)
+
LIBS=$saved_LIBS
dnl ======================
@@ -282,7 +287,7 @@ AC_TRY_COMPILE(
dnl check if pthread_condattr_setclock(CLOCK_MONOTONE) is supported
saved_LIBS=$LIBS
-LIBS="-lpthread"
+LIBS=$PTHREADLIB
AC_MSG_CHECKING([for pthread_condattr_setclock(CLOCK_MONOTONE)])
AC_TRY_RUN(
[#include <pthread.h>