aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Willi <martin@strongswan.org>2009-08-11 16:24:01 +0200
committerMartin Willi <martin@strongswan.org>2009-08-26 11:23:48 +0200
commit160f4c225db0deacc3670c4cff0609bda8e29f73 (patch)
tree4405b13114c9cba9f8f949ec2cb626b758e6b448 /configure.in
parent5672eae131e834acacc12ffbf08b5a4486affc96 (diff)
downloadstrongswan-160f4c225db0deacc3670c4cff0609bda8e29f73.tar.bz2
strongswan-160f4c225db0deacc3670c4cff0609bda8e29f73.tar.xz
moved PEM parsing functionality to its own plugin
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 04dfe868b..97bd331b1 100644
--- a/configure.in
+++ b/configure.in
@@ -288,6 +288,17 @@ AC_ARG_ENABLE(
)
AC_ARG_ENABLE(
+ [pem],
+ AS_HELP_STRING([--disable-pem],[disable PEM decoding plugin. (default is NO).]),
+ [if test x$enableval = xyes; then
+ pem=true
+ else
+ pem=false
+ fi],
+ pem=true
+)
+
+AC_ARG_ENABLE(
[hmac],
AS_HELP_STRING([--disable-hmac],[disable HMAC crypto implementation plugin. (default is NO).]),
[if test x$enableval = xyes; then
@@ -1181,6 +1192,10 @@ if test x$pubkey = xtrue; then
libstrongswan_plugins=${libstrongswan_plugins}" pubkey"
pluto_plugins=${pluto_plugins}" pubkey"
fi
+if test x$pem = xtrue; then
+ libstrongswan_plugins=${libstrongswan_plugins}" pem"
+ pluto_plugins=${pluto_plugins}" pem"
+fi
if test x$mysql = xtrue; then
libstrongswan_plugins=${libstrongswan_plugins}" mysql"
fi
@@ -1237,6 +1252,7 @@ AM_CONDITIONAL(USE_GMP, test x$gmp = xtrue)
AM_CONDITIONAL(USE_RANDOM, test x$random = xtrue)
AM_CONDITIONAL(USE_X509, test x$x509 = xtrue)
AM_CONDITIONAL(USE_PUBKEY, test x$pubkey = xtrue)
+AM_CONDITIONAL(USE_PEM, test x$pem = xtrue)
AM_CONDITIONAL(USE_HMAC, test x$hmac = xtrue)
AM_CONDITIONAL(USE_XCBC, test x$xcbc = xtrue)
AM_CONDITIONAL(USE_MYSQL, test x$mysql = xtrue)
@@ -1331,6 +1347,7 @@ AC_OUTPUT(
src/libstrongswan/plugins/xcbc/Makefile
src/libstrongswan/plugins/x509/Makefile
src/libstrongswan/plugins/pubkey/Makefile
+ src/libstrongswan/plugins/pem/Makefile
src/libstrongswan/plugins/curl/Makefile
src/libstrongswan/plugins/ldap/Makefile
src/libstrongswan/plugins/mysql/Makefile