aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTobias Brunner <tobias@strongswan.org>2008-04-28 14:25:19 +0000
committerTobias Brunner <tobias@strongswan.org>2008-04-28 14:25:19 +0000
commit17353034f35cbb06e315d02b57a9b7319909b6ea (patch)
tree46a292c70eae1c8e9973a87f733488ca485f570d /configure.in
parent1da06b295ff1571d446dc81babd40fca1f655ca9 (diff)
downloadstrongswan-17353034f35cbb06e315d02b57a9b7319909b6ea.tar.bz2
strongswan-17353034f35cbb06e315d02b57a9b7319909b6ea.tar.xz
added a wrapper plugin for OpenSSL crypters (AES, 3DES, Blowfish etc.)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 9ec34b878..30a9f282d 100644
--- a/configure.in
+++ b/configure.in
@@ -496,6 +496,16 @@ AC_ARG_ENABLE(
fi],
)
+AC_ARG_ENABLE(
+ [openssl],
+ AS_HELP_STRING([--enable-openssl],[enables the OpenSSL crypto plugin. (default is NO).]),
+ [if test x$enableval = xyes; then
+ openssl=true
+ else
+ openssl=false
+ fi],
+)
+
dnl =========================
dnl check required programs
dnl =========================
@@ -597,6 +607,11 @@ if test x$mysql = xtrue; then
AC_CHECK_HEADER([sqlite3.h],,[AC_MSG_ERROR([SQLite header sqlite3.h not found!])])
fi
+if test x$openssl = xtrue; then
+ AC_HAVE_LIBRARY([ssl],[LIBS="$LIBS"],[AC_MSG_ERROR([OpenSSL library ssl not found])])
+ AC_CHECK_HEADER([openssl/evp.h],,[AC_MSG_ERROR([OpenSSL header openssl/evp.h not found!])])
+fi
+
dnl =========================
dnl set Makefile.am vars
dnl =========================
@@ -643,6 +658,7 @@ AM_CONDITIONAL(USE_PLUTO_OR_CHARON, test x$pluto = xtrue -o x$charon = xtrue)
AM_CONDITIONAL(USE_LIBSTRONGSWAN, test x$charon = xtrue -o x$tools = xtrue)
AM_CONDITIONAL(USE_FILE_CONFIG, test x$pluto = xtrue -o x$stroke = xtrue)
AM_CONDITIONAL(USE_PADLOCK, test x$padlock = xtrue)
+AM_CONDITIONAL(USE_OPENSSL, test x$openssl = xtrue)
dnl ==============================
dnl set global definitions
@@ -676,6 +692,7 @@ AC_OUTPUT(
src/libstrongswan/plugins/mysql/Makefile
src/libstrongswan/plugins/sqlite/Makefile
src/libstrongswan/plugins/padlock/Makefile
+ src/libstrongswan/plugins/openssl/Makefile
src/libcrypto/Makefile
src/libfreeswan/Makefile
src/pluto/Makefile