aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Willi <martin@strongswan.org>2008-06-06 08:24:39 +0000
committerMartin Willi <martin@strongswan.org>2008-06-06 08:24:39 +0000
commit1e9c46f13daced3199953f4d1758c7e03c935083 (patch)
tree5fc059daab22e616a60f0efdc0309119e58ad47b /configure.in
parent915e04b2dd946650ee5c18ff6c0322db1b2d8e9b (diff)
downloadstrongswan-1e9c46f13daced3199953f4d1758c7e03c935083.tar.bz2
strongswan-1e9c46f13daced3199953f4d1758c7e03c935083.tar.xz
configure option for updown firewall scripts
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 939e6c486..05d4db477 100644
--- a/configure.in
+++ b/configure.in
@@ -525,6 +525,17 @@ AC_ARG_ENABLE(
)
AC_ARG_ENABLE(
+ [updown],
+ AS_HELP_STRING([--disable-updown],[disable installation of firewall scripts. (default is NO).]),
+ [if test x$enableval = xyes; then
+ updown=true
+ else
+ updown=false
+ fi],
+ updown=true
+)
+
+AC_ARG_ENABLE(
[padlock],
AS_HELP_STRING([--enable-padlock],[enables VIA Padlock crypto plugin. (default is NO).]),
[if test x$enableval = xyes; then
@@ -789,7 +800,7 @@ AM_CONDITIONAL(USE_SELF_TEST, test x$self_test = xtrue)
AM_CONDITIONAL(USE_PLUTO, test x$pluto = xtrue)
AM_CONDITIONAL(USE_CHARON, test x$charon = xtrue)
AM_CONDITIONAL(USE_TOOLS, test x$tools = xtrue)
-AM_CONDITIONAL(USE_PLUTO_OR_CHARON, test x$pluto = xtrue -o x$charon = xtrue)
+AM_CONDITIONAL(USE_UPDOWN, test x$updown = xtrue)
AM_CONDITIONAL(USE_LIBSTRONGSWAN, test x$charon = xtrue -o x$tools = xtrue)
AM_CONDITIONAL(USE_FILE_CONFIG, test x$pluto = xtrue -o x$stroke = xtrue)