aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Willi <martin@strongswan.org>2008-05-08 10:58:04 +0000
committerMartin Willi <martin@strongswan.org>2008-05-08 10:58:04 +0000
commit25b12c696bf52b7ddb228458bba656d25a6222d4 (patch)
tree6c9fa89a5fc25ac3923415901aa94a2448295769 /configure.in
parent97e820f5fdbd7987003cb086a02f7ee2f2a6ccee (diff)
downloadstrongswan-25b12c696bf52b7ddb228458bba656d25a6222d4.tar.bz2
strongswan-25b12c696bf52b7ddb228458bba656d25a6222d4.tar.xz
replaced --with-gid/uid by --with-group/user
using named users, groups fixed capability dropping in pluto
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 16 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index d9473fd1c..b29ce3a8c 100644
--- a/configure.in
+++ b/configure.in
@@ -118,17 +118,25 @@ AC_ARG_WITH(
)
AC_ARG_WITH(
- [uid],
- AS_HELP_STRING([--with-uid=uid],[change user of the daemons to UID after startup (default is 0).]),
- [AC_DEFINE_UNQUOTED(IPSEC_UID, $withval) AC_SUBST(ipsecuid, "$withval")],
- [AC_DEFINE_UNQUOTED(IPSEC_UID, 0) AC_SUBST(ipsecuid, "0")]
+ [uid],,[AC_MSG_ERROR([--with-uid is gone, use --with-user instead!])]
)
AC_ARG_WITH(
- [gid],
- AS_HELP_STRING([--with-gid=gid],[change group of the daemons to GID after startup (default is 0).]),
- [AC_DEFINE_UNQUOTED(IPSEC_GID, $withval) AC_SUBST(ipsecgid, "$withval")],
- [AC_DEFINE_UNQUOTED(IPSEC_GID, 0) AC_SUBST(ipsecgid, "0")]
+ [gid],,[AC_MSG_ERROR([--with-gid is gone, use --with-group instead!])]
+)
+
+AC_ARG_WITH(
+ [user],
+ AS_HELP_STRING([--with-user=user],[change user of the daemons to "user" after startup (default is 0).]),
+ [AC_DEFINE_UNQUOTED(IPSEC_USER, "$withval") AC_SUBST(ipsecuser, "$withval")],
+ [AC_SUBST(ipsecuser, "root")]
+)
+
+AC_ARG_WITH(
+ [group],
+ AS_HELP_STRING([--with-group=group],[change group of the daemons to "group" after startup (default is 0).]),
+ [AC_DEFINE_UNQUOTED(IPSEC_GROUP, "$withval") AC_SUBST(ipsecgroup, "$withval")],
+ [AC_SUBST(ipsecgroup, "root")]
)
AC_ARG_ENABLE(