aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTobias Brunner <tobias@strongswan.org>2009-08-14 14:42:03 +0200
committerTobias Brunner <tobias@strongswan.org>2009-08-14 14:50:53 +0200
commit26965b4ef3758e44b90f7574c8d204afe5923ab6 (patch)
treea2a8e2f1f7a248fe31a3a5b17b8a9f7987f8817c /configure.in
parent932fdc38de553b35e4afb1c03bb013881d5144a8 (diff)
downloadstrongswan-26965b4ef3758e44b90f7574c8d204afe5923ab6.tar.bz2
strongswan-26965b4ef3758e44b90f7574c8d204afe5923ab6.tar.xz
OpenSolaris needs libsocket and libnsl for socket().
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 909b7249f..9c811a5c4 100644
--- a/configure.in
+++ b/configure.in
@@ -850,7 +850,7 @@ dnl libraries needed on some platforms but not on others
dnl ====================================================
saved_LIBS=$LIBS
-dnl FreeBSD has dlopen integrated in libc, Linux needs libdl
+dnl FreeBSD and Mac OS X have dlopen integrated in libc, Linux needs libdl
LIBS=""
AC_SEARCH_LIBS(dlopen, dl, [DLLIB=$LIBS])
AC_SUBST(DLLIB)
@@ -861,6 +861,13 @@ AC_SEARCH_LIBS(backtrace, execinfo, [BTLIB=$LIBS])
AC_CHECK_FUNCS(backtrace)
AC_SUBST(BTLIB)
+dnl OpenSolaris needs libsocket and libnsl for socket()
+LIBS=""
+AC_SEARCH_LIBS(socket, socket, [SOCKLIB=$LIBS],
+ [AC_CHECK_LIB(nsl, socket, [SOCKLIB="-lsocket -lnsl"], [], [-lsocket])]
+)
+AC_SUBST(SOCKLIB)
+
LIBS=$saved_LIBS
dnl ======================