aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTobias Brunner <tobias@strongswan.org>2011-12-12 18:26:26 +0100
committerTobias Brunner <tobias@strongswan.org>2012-03-20 17:31:17 +0100
commit3d44d735c649559b9768ae635a6bee7fec932902 (patch)
treea83022a6186310b80f35b112ce38ab5644afca1b /configure.in
parent41e1e435d9c70c28c3e38074d34c43e639ae79e6 (diff)
downloadstrongswan-3d44d735c649559b9768ae635a6bee7fec932902.tar.bz2
strongswan-3d44d735c649559b9768ae635a6bee7fec932902.tar.xz
Added generic XAuth backend, using secrets provided by credential sets.
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5ab5417a8..0be86058a 100755
--- a/configure.in
+++ b/configure.in
@@ -129,6 +129,7 @@ ARG_ENABL_SET([eap-ttls], [enable EAP TTLS authentication module.])
ARG_ENABL_SET([eap-peap], [enable EAP PEAP authentication module.])
ARG_ENABL_SET([eap-tnc], [enable EAP TNC trusted network connect module.])
ARG_ENABL_SET([eap-radius], [enable RADIUS proxy authentication module.])
+ARG_ENABL_SET([xauth-generic], [enable generic XAuth backend.])
ARG_ENABL_SET([tnc-ifmap], [enable TNC IF-MAP module.])
ARG_ENABL_SET([tnc-imc], [enable TNC IMC module.])
ARG_ENABL_SET([tnc-imv], [enable TNC IMV module.])
@@ -842,6 +843,7 @@ ADD_PLUGIN([eap-tls], [c libcharon])
ADD_PLUGIN([eap-ttls], [c libcharon])
ADD_PLUGIN([eap-peap], [c libcharon])
ADD_PLUGIN([eap-tnc], [c libcharon])
+ADD_PLUGIN([xauth-generic], [c libcharon])
ADD_PLUGIN([tnc-ifmap], [c libcharon])
ADD_PLUGIN([tnc-imc], [c libcharon])
ADD_PLUGIN([tnc-imv], [c libcharon])
@@ -961,6 +963,7 @@ AM_CONDITIONAL(USE_EAP_TTLS, test x$eap_ttls = xtrue)
AM_CONDITIONAL(USE_EAP_PEAP, test x$eap_peap = xtrue)
AM_CONDITIONAL(USE_EAP_TNC, test x$eap_tnc = xtrue)
AM_CONDITIONAL(USE_EAP_RADIUS, test x$eap_radius = xtrue)
+AM_CONDITIONAL(USE_XAUTH_GENERIC, test x$xauth_generic = xtrue)
AM_CONDITIONAL(USE_TNC_IFMAP, test x$tnc_ifmap = xtrue)
AM_CONDITIONAL(USE_TNC_IMC, test x$tnc_imc = xtrue)
AM_CONDITIONAL(USE_TNC_IMV, test x$tnc_imv = xtrue)
@@ -1139,6 +1142,7 @@ AC_OUTPUT(
src/libcharon/plugins/eap_peap/Makefile
src/libcharon/plugins/eap_tnc/Makefile
src/libcharon/plugins/eap_radius/Makefile
+ src/libcharon/plugins/xauth_generic/Makefile
src/libcharon/plugins/tnc_ifmap/Makefile
src/libcharon/plugins/tnc_imc/Makefile
src/libcharon/plugins/tnc_imv/Makefile