aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Willi <martin@strongswan.org>2010-02-17 09:41:55 +0000
committerMartin Willi <martin@strongswan.org>2010-02-17 18:24:11 +0100
commit55699f037f147f41106a59a934cb661be2a9598d (patch)
tree5f47b128ca207e73d13cba3ddf00d25081f93e39 /configure.in
parent63b0bc9c2dc320f942bf089243334be90ea6b7f0 (diff)
downloadstrongswan-55699f037f147f41106a59a934cb661be2a9598d.tar.bz2
strongswan-55699f037f147f41106a59a934cb661be2a9598d.tar.xz
Added Android plugin, currently provides DNS handling on Android
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3944aa44f..be76ae851 100644
--- a/configure.in
+++ b/configure.in
@@ -135,6 +135,7 @@ ARG_ENABL_SET([openssl], [enables the OpenSSL crypto plugin.])
ARG_ENABL_SET([gcrypt], [enables the libgcrypt plugin.])
ARG_ENABL_SET([agent], [enables the ssh-agent signing plugin.])
ARG_ENABL_SET([uci], [enable OpenWRT UCI configuration plugin.])
+ARG_ENABL_SET([android], [enable Android specific plugin.])
ARG_ENABL_SET([nm], [enable NetworkManager plugin.])
ARG_ENABL_SET([vstr], [enforce using the Vstr string library to replace glibc-like printf hooks.])
@@ -554,6 +555,11 @@ if test x$uci = xtrue; then
AC_CHECK_HEADER([uci.h],,[AC_MSG_ERROR([UCI header uci.h not found!])])
fi
+if test x$android = xtrue; then
+ AC_HAVE_LIBRARY([cutils],[LIBS="$LIBS"],[AC_MSG_ERROR([Android library libcutils not found])])
+ AC_CHECK_HEADER([cutils/properties.h],,[AC_MSG_ERROR([Android header cutils/properties.h not found!])])
+fi
+
if test x$nm = xtrue; then
PKG_CHECK_EXISTS([libnm-glib],
[PKG_CHECK_MODULES(nm, [NetworkManager gthread-2.0 libnm-glib libnm-glib-vpn])],
@@ -752,6 +758,7 @@ AM_CONDITIONAL(USE_MEDSRV, test x$medsrv = xtrue)
AM_CONDITIONAL(USE_MEDCLI, test x$medcli = xtrue)
AM_CONDITIONAL(USE_NM, test x$nm = xtrue)
AM_CONDITIONAL(USE_UCI, test x$uci = xtrue)
+AM_CONDITIONAL(USE_ANDROID, test x$android = xtrue)
AM_CONDITIONAL(USE_SMP, test x$smp = xtrue)
AM_CONDITIONAL(USE_SQL, test x$sql = xtrue)
AM_CONDITIONAL(USE_UPDOWN, test x$updown = xtrue)
@@ -874,6 +881,7 @@ AC_OUTPUT(
src/charon/plugins/medcli/Makefile
src/charon/plugins/nm/Makefile
src/charon/plugins/uci/Makefile
+ src/charon/plugins/android/Makefile
src/charon/plugins/stroke/Makefile
src/charon/plugins/updown/Makefile
src/charon/plugins/attr/Makefile