aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Willi <martin@strongswan.org>2008-04-15 05:56:35 +0000
committerMartin Willi <martin@strongswan.org>2008-04-15 05:56:35 +0000
commit6a365f0740ff683de52751c1c2903b0ddb6a7e0c (patch)
tree0b2039f3975676490b4f713ae52db81e747a5314 /configure.in
parent0644ebd3de62e1df38fce4373460a9d1d2957981 (diff)
downloadstrongswan-6a365f0740ff683de52751c1c2903b0ddb6a7e0c.tar.bz2
strongswan-6a365f0740ff683de52751c1c2903b0ddb6a7e0c.tar.xz
added API for random number generators, served through credential factory
ported randomizer_t to a rng_t on top of /dev/(u)random (plugin random)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 9e0de9cd4..f9824bbb2 100644
--- a/configure.in
+++ b/configure.in
@@ -224,6 +224,17 @@ AC_ARG_ENABLE(
)
AC_ARG_ENABLE(
+ [random],
+ AS_HELP_STRING([--disable-random],[disable RNG implementation on top of /dev/(u)random. (default is NO).]),
+ [if test x$enableval = xyes; then
+ random=true
+ else
+ random=false
+ fi],
+ random=true
+)
+
+AC_ARG_ENABLE(
[x509],
AS_HELP_STRING([--disable-x509],[disable own X509 certificate implementation plugin. (default is NO).]),
[if test x$enableval = xyes; then
@@ -589,6 +600,7 @@ AM_CONDITIONAL(USE_SHA1, test x$sha1 = xtrue)
AM_CONDITIONAL(USE_SHA2, test x$sha2 = xtrue)
AM_CONDITIONAL(USE_FIPS_PRF, test x$fips_prf = xtrue)
AM_CONDITIONAL(USE_GMP, test x$gmp = xtrue)
+AM_CONDITIONAL(USE_RANDOM, test x$random = xtrue)
AM_CONDITIONAL(USE_X509, test x$x509 = xtrue)
AM_CONDITIONAL(USE_HMAC, test x$hmac = xtrue)
AM_CONDITIONAL(USE_MYSQL, test x$mysql = xtrue)
@@ -645,6 +657,7 @@ AC_OUTPUT(
src/libstrongswan/plugins/sha2/Makefile
src/libstrongswan/plugins/fips_prf/Makefile
src/libstrongswan/plugins/gmp/Makefile
+ src/libstrongswan/plugins/random/Makefile
src/libstrongswan/plugins/hmac/Makefile
src/libstrongswan/plugins/x509/Makefile
src/libstrongswan/plugins/curl/Makefile