aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Willi <martin@strongswan.org>2009-06-11 11:09:33 +0200
committerMartin Willi <martin@strongswan.org>2009-06-11 15:55:59 +0200
commit81811a9d8bb4c1a46353801e035506114c55799c (patch)
tree402da94839511da7572b46013cc3f67cc4ced869 /configure.in
parent28a0728b679709dbe59cf7bd3052772f6059c4b5 (diff)
downloadstrongswan-81811a9d8bb4c1a46353801e035506114c55799c.tar.bz2
strongswan-81811a9d8bb4c1a46353801e035506114c55799c.tar.xz
added a plugin providing crypto test vectors
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 63f7baaf9..438a24b49 100644
--- a/configure.in
+++ b/configure.in
@@ -326,6 +326,14 @@ AC_ARG_ENABLE(
)
AC_ARG_ENABLE(
+ [test-vectors],
+ AS_HELP_STRING([--enable-test-vectprs],[enable plugin providing crypto test vectors (default is NO).]),
+ [if test x$enableval = xyes; then
+ test_vectors=true
+ fi]
+)
+
+AC_ARG_ENABLE(
[mysql],
AS_HELP_STRING([--enable-mysql],[enable MySQL database support (default is NO). Requires libmysqlclient_r.]),
[if test x$enableval = xyes; then
@@ -1048,6 +1056,10 @@ dnl ======================================
libstrongswan_plugins=
pluto_plugins=
+if test x$test_vectors = xtrue; then
+ libstrongswan_plugins=${libstrongswan_plugins}" test-vectors"
+ pluto_plugins=${pluto_plugins}" test-vectors"
+fi
if test x$curl = xtrue; then
libstrongswan_plugins=${libstrongswan_plugins}" curl"
pluto_plugins=${pluto_plugins}" curl"
@@ -1144,6 +1156,7 @@ dnl =========================
dnl libstrongswan plugins
dnl =====================
+AM_CONDITIONAL(USE_TEST_VECTORS, test x$test_vectors = xtrue)
AM_CONDITIONAL(USE_CURL, test x$curl = xtrue)
AM_CONDITIONAL(USE_LDAP, test x$ldap = xtrue)
AM_CONDITIONAL(USE_AES, test x$aes = xtrue)
@@ -1264,6 +1277,7 @@ AC_OUTPUT(
src/libstrongswan/plugins/openssl/Makefile
src/libstrongswan/plugins/gcrypt/Makefile
src/libstrongswan/plugins/agent/Makefile
+ src/libstrongswan/plugins/test_vectors/Makefile
src/libstrongswan/fips/Makefile
src/libfreeswan/Makefile
src/pluto/Makefile