aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Willi <martin@strongswan.org>2009-09-23 12:45:03 +0200
committerMartin Willi <martin@strongswan.org>2009-09-23 12:45:03 +0200
commit840743479a77359d841a20a04e6cb6d6d05eb264 (patch)
tree8c8b0e9aad94b7243fc825b0db978afd6b9e55ee /configure.in
parent0406ed7a166e732f1b237ecf6198922825f027a7 (diff)
downloadstrongswan-840743479a77359d841a20a04e6cb6d6d05eb264.tar.bz2
strongswan-840743479a77359d841a20a04e6cb6d6d05eb264.tar.xz
Use mysql_config to query MySQL LIBS and CFLAGS
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 2b0f9a81b..8b4d6a428 100644
--- a/configure.in
+++ b/configure.in
@@ -445,8 +445,12 @@ dnl AC_CHECK_HEADER([ClearSilver/ClearSilver.h],,[AC_MSG_ERROR([ClearSilver head
fi
if test x$mysql = xtrue; then
- AC_HAVE_LIBRARY([mysqlclient_r],[LIBS="$LIBS"],[AC_MSG_ERROR([MySQL library mysqlclient_r not found])])
- AC_CHECK_HEADER([mysql/mysql.h],,[AC_MSG_ERROR([MySQL header mysql/mysql.h not found!])])
+ AC_PATH_PROG([MYSQLCONFIG], [mysql_config], [], [$PATH:/bin:/usr/bin:/usr/local/bin])
+ if test x$MYSQLCONFIG = x; then
+ AC_MSG_ERROR([mysql_config not found!])
+ fi
+ AC_SUBST(MYSQLLIB, `$MYSQLCONFIG --libs_r`)
+ AC_SUBST(MYSQLCFLAG, `$MYSQLCONFIG --cflags`)
fi
if test x$sqlite = xtrue; then