aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Willi <martin@strongswan.org>2009-08-17 13:46:04 +0200
committerMartin Willi <martin@strongswan.org>2009-08-26 11:23:50 +0200
commit9493dd2ce0b0330cf8874cc5b474822f33eff6b7 (patch)
treeec1c688b0a12d02c39518428de1172f9a5c264a5 /configure.in
parent4e3d1e804e834b961ca488407f24d6f4a39312cd (diff)
downloadstrongswan-9493dd2ce0b0330cf8874cc5b474822f33eff6b7.tar.bz2
strongswan-9493dd2ce0b0330cf8874cc5b474822f33eff6b7.tar.xz
implemented a pgp plugin providing PGP key parsing builders
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 73941db43..dca56c999 100644
--- a/configure.in
+++ b/configure.in
@@ -299,6 +299,17 @@ AC_ARG_ENABLE(
)
AC_ARG_ENABLE(
+ [pgp],
+ AS_HELP_STRING([--disable-pkcs],[disable PGP key decoding plugin. (default is NO).]),
+ [if test x$enableval = xyes; then
+ pgp=true
+ else
+ pgp=false
+ fi],
+ pgp=true
+)
+
+AC_ARG_ENABLE(
[pem],
AS_HELP_STRING([--disable-pem],[disable PEM decoding plugin. (default is NO).]),
[if test x$enableval = xyes; then
@@ -1207,6 +1218,10 @@ if test x$pkcs1 = xtrue; then
libstrongswan_plugins=${libstrongswan_plugins}" pkcs1"
pluto_plugins=${pluto_plugins}" pkcs1"
fi
+if test x$pgp = xtrue; then
+ libstrongswan_plugins=${libstrongswan_plugins}" pgp"
+ pluto_plugins=${pluto_plugins}" pgp"
+fi
if test x$pem = xtrue; then
libstrongswan_plugins=${libstrongswan_plugins}" pem"
pluto_plugins=${pluto_plugins}" pem"
@@ -1268,6 +1283,7 @@ AM_CONDITIONAL(USE_RANDOM, test x$random = xtrue)
AM_CONDITIONAL(USE_X509, test x$x509 = xtrue)
AM_CONDITIONAL(USE_PUBKEY, test x$pubkey = xtrue)
AM_CONDITIONAL(USE_PKCS1, test x$pkcs1 = xtrue)
+AM_CONDITIONAL(USE_PGP, test x$pgp = xtrue)
AM_CONDITIONAL(USE_PEM, test x$pem = xtrue)
AM_CONDITIONAL(USE_HMAC, test x$hmac = xtrue)
AM_CONDITIONAL(USE_XCBC, test x$xcbc = xtrue)
@@ -1364,6 +1380,7 @@ AC_OUTPUT(
src/libstrongswan/plugins/x509/Makefile
src/libstrongswan/plugins/pubkey/Makefile
src/libstrongswan/plugins/pkcs1/Makefile
+ src/libstrongswan/plugins/pgp/Makefile
src/libstrongswan/plugins/pem/Makefile
src/libstrongswan/plugins/curl/Makefile
src/libstrongswan/plugins/ldap/Makefile