aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTobias Brunner <tobias@strongswan.org>2011-11-09 12:08:40 +0100
committerTobias Brunner <tobias@strongswan.org>2012-03-20 17:30:39 +0100
commitccdd3a4cee90a419b666a571664c8d4aeb44590b (patch)
treebbcfb236e3dff07e59a47b7b2ea1360e4f0fa527 /configure.in
parent99246a4fc2523ed6675c6b81b49b0fa4258f847d (diff)
downloadstrongswan-ccdd3a4cee90a419b666a571664c8d4aeb44590b.tar.bz2
strongswan-ccdd3a4cee90a419b666a571664c8d4aeb44590b.tar.xz
Added configure option for the IKEv1 implementation in charon.
Diffstat (limited to 'configure.in')
-rwxr-xr-x[-rw-r--r--]configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 66daeb6b8..893914251 100644..100755
--- a/configure.in
+++ b/configure.in
@@ -158,7 +158,8 @@ ARG_ENABL_SET([manager], [enable web management console (proof of concept
ARG_ENABL_SET([mediation], [enable IKEv2 Mediation Extension.])
ARG_ENABL_SET([integrity-test], [enable integrity testing of libstrongswan and plugins.])
ARG_DISBL_SET([load-warning], [disable the charon/pluto plugin load option warning in starter.])
-ARG_DISBL_SET([pluto], [disable the IKEv1 keying daemon pluto.])
+ARG_ENABL_SET([pluto], [enable the IKEv1 keying daemon pluto.])
+ARG_DISBL_SET([ikev1], [disable IKEv1 protocol support in charon.])
ARG_DISBL_SET([xauth], [disable xauth plugin.])
ARG_DISBL_SET([threads], [disable the use of threads in pluto. Charon always uses threads.])
ARG_DISBL_SET([adns], [disable the use of adns in pluto (disables opportunistic encryption).])
@@ -1009,6 +1010,7 @@ AM_CONDITIONAL(USE_ME, test x$mediation = xtrue)
AM_CONDITIONAL(USE_INTEGRITY_TEST, test x$integrity_test = xtrue)
AM_CONDITIONAL(USE_LOAD_WARNING, test x$load_warning = xtrue)
AM_CONDITIONAL(USE_PLUTO, test x$pluto = xtrue)
+AM_CONDITIONAL(USE_IKEV1, test x$ikev1 = xtrue)
AM_CONDITIONAL(USE_THREADS, test x$threads = xtrue)
AM_CONDITIONAL(USE_ADNS, test x$adns = xtrue)
AM_CONDITIONAL(USE_CHARON, test x$charon = xtrue)
@@ -1043,7 +1045,9 @@ fi
if test x$monolithic = xtrue; then
AC_DEFINE(MONOLITHIC)
fi
-
+if test x$ikev1 = xtrue; then
+ AC_DEFINE(USE_IKEV1)
+fi
dnl ==============================
dnl build Makefiles