aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTobias Brunner <tobias@strongswan.org>2009-07-16 10:52:14 +0200
committerTobias Brunner <tobias@strongswan.org>2009-07-16 15:15:26 +0200
commitcf00cffef237014486eecd0aa04ed8601a7d5265 (patch)
treea3fcdf8fad6aebddbf0ff18935b6b9fb28abef82 /configure.in
parent599d2bcea821c32d742d9973d65d96c99aedc1a6 (diff)
downloadstrongswan-cf00cffef237014486eecd0aa04ed8601a7d5265.tar.bz2
strongswan-cf00cffef237014486eecd0aa04ed8601a7d5265.tar.xz
Added an option to the configure script to disable building the scripts.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 6a3cfac4f..42fc7d59b 100644
--- a/configure.in
+++ b/configure.in
@@ -639,6 +639,17 @@ AC_ARG_ENABLE(
)
AC_ARG_ENABLE(
+ [scripts],
+ AS_HELP_STRING([--disable-scripts],[disable additional utilities (found in directory scripts). (default is NO).]),
+ [if test x$enableval = xyes; then
+ scripts=true
+ else
+ scripts=false
+ fi],
+ scripts=true
+)
+
+AC_ARG_ENABLE(
[updown],
AS_HELP_STRING([--disable-updown],[disable updown firewall script plugin. (default is NO).]),
[if test x$enableval = xyes; then
@@ -1230,6 +1241,7 @@ AM_CONDITIONAL(USE_PLUTO, test x$pluto = xtrue)
AM_CONDITIONAL(USE_THREADS, test x$threads = xtrue)
AM_CONDITIONAL(USE_CHARON, test x$charon = xtrue)
AM_CONDITIONAL(USE_TOOLS, test x$tools = xtrue)
+AM_CONDITIONAL(USE_SCRIPTS, test x$scripts = xtrue)
AM_CONDITIONAL(USE_LIBSTRONGSWAN, test x$charon = xtrue -o x$pluto = xtrue -o x$tools = xtrue)
AM_CONDITIONAL(USE_FILE_CONFIG, test x$pluto = xtrue -o x$stroke = xtrue)
AM_CONDITIONAL(USE_VSTR, test x$vstr = xtrue)