aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Willi <martin@revosec.ch>2012-02-27 15:18:58 +0100
committerMartin Willi <martin@revosec.ch>2012-03-05 18:08:04 +0100
commitf0f94e2ce6eac9893498c50e5155a0085229fe8c (patch)
treeb73b09693a5de5d87f1b07e2be051a523a6abbb6 /configure.in
parent990fda9d881e502e2974fc9f6feb07cefce1aa6b (diff)
downloadstrongswan-f0f94e2ce6eac9893498c50e5155a0085229fe8c.tar.bz2
strongswan-f0f94e2ce6eac9893498c50e5155a0085229fe8c.tar.xz
Moved generic RADIUS protocol support to a dedicated libradius
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2b13a949f..a463c4826 100644
--- a/configure.in
+++ b/configure.in
@@ -252,6 +252,10 @@ if test x$eap_tls = xtrue -o x$eap_ttls = xtrue -o x$eap_peap = xtrue; then
tls=true;
fi
+if test x$eap_radius = xtrue; then
+ radius=true;
+fi
+
if test x$tnc_imc = xtrue -o x$tnc_imv = xtrue -o x$tnccs_11 = xtrue -o x$tnccs_11 = xtrue -o x$tnccs_dynamic = xtrue -o x$eap_tnc = xtrue; then
tnc_tnccs=true;
fi
@@ -1052,6 +1056,7 @@ AM_CONDITIONAL(USE_LIBCAP, test x$capabilities = xlibcap)
AM_CONDITIONAL(USE_VSTR, test x$vstr = xtrue)
AM_CONDITIONAL(USE_SIMAKA, test x$simaka = xtrue)
AM_CONDITIONAL(USE_TLS, test x$tls = xtrue)
+AM_CONDITIONAL(USE_RADIUS, test x$radius = xtrue)
AM_CONDITIONAL(USE_IMCV, test x$imcv = xtrue)
AM_CONDITIONAL(USE_PTS, test x$pts = xtrue)
AM_CONDITIONAL(MONOLITHIC, test x$monolithic = xtrue)
@@ -1130,6 +1135,7 @@ AC_OUTPUT(
src/libfreeswan/Makefile
src/libsimaka/Makefile
src/libtls/Makefile
+ src/libradius/Makefile
src/libtncif/Makefile
src/libtnccs/Makefile
src/libpts/Makefile