aboutsummaryrefslogtreecommitdiffstats
path: root/fuzz/Makefile.am
diff options
context:
space:
mode:
authorTobias Brunner <tobias@strongswan.org>2017-05-31 14:37:27 +0200
committerTobias Brunner <tobias@strongswan.org>2017-08-15 10:35:20 +0200
commitbf31485e1eed4d6b313405a2088ad3884120e714 (patch)
treee95c8d4d46f030bc5cf5702e5d2389312285a871 /fuzz/Makefile.am
parent17840fa18ee1439e136ee555a637b623c6bfbda1 (diff)
downloadstrongswan-bf31485e1eed4d6b313405a2088ad3884120e714.tar.bz2
strongswan-bf31485e1eed4d6b313405a2088ad3884120e714.tar.xz
fuzzing: Also run input that previously caused crashes
Diffstat (limited to 'fuzz/Makefile.am')
-rw-r--r--fuzz/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/fuzz/Makefile.am b/fuzz/Makefile.am
index 927ace78b..bdc3e2ebc 100644
--- a/fuzz/Makefile.am
+++ b/fuzz/Makefile.am
@@ -26,4 +26,6 @@ check: all
corpus=$${f#fuzz_}; \
corpus=$${corpus%%_*}; \
./$$f $(FUZZING_CORPORA)/$${corpus}/*; \
+ crashes=$(FUZZING_CORPORA)/$${corpus}-crash; \
+ test ! -d $${crashes} || ./$$f $${crashes}/*; \
done