aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMartin Willi <martin@strongswan.org>2008-05-08 10:58:04 +0000
committerMartin Willi <martin@strongswan.org>2008-05-08 10:58:04 +0000
commit25b12c696bf52b7ddb228458bba656d25a6222d4 (patch)
tree6c9fa89a5fc25ac3923415901aa94a2448295769 /src/Makefile.am
parent97e820f5fdbd7987003cb086a02f7ee2f2a6ccee (diff)
downloadstrongswan-25b12c696bf52b7ddb228458bba656d25a6222d4.tar.bz2
strongswan-25b12c696bf52b7ddb228458bba656d25a6222d4.tar.xz
replaced --with-gid/uid by --with-group/user
using named users, groups fixed capability dropping in pluto
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3ed61dfc7..1322dda28 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -42,5 +42,5 @@ endif
EXTRA_DIST = strongswan.conf
install-exec-local :
- test -e "$(DESTDIR)${sysconfdir}" || $(MKDIR_P) "$(DESTDIR)$(sysconfdir)"
- test -e "$(DESTDIR)$(sysconfdir)/strongswan.conf" || $(INSTALL) -m 600 strongswan.conf $(DESTDIR)$(sysconfdir)/strongswan.conf
+ test -e "$(DESTDIR)${sysconfdir}" || $(INSTALL) -d "$(DESTDIR)$(sysconfdir)"
+ test -e "$(DESTDIR)$(sysconfdir)/strongswan.conf" || $(INSTALL) -o ${ipsecuser} -g ${ipsecgroup} -m 640 strongswan.conf $(DESTDIR)$(sysconfdir)/strongswan.conf