aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMartin Willi <martin@strongswan.org>2008-04-18 12:52:47 +0000
committerMartin Willi <martin@strongswan.org>2008-04-18 12:52:47 +0000
commit66bb16b0337e326fe9403e65549b0846fd1becaf (patch)
tree668856fba6aeb5532b6ceb6906ac35931c299ebd /src/Makefile.am
parentbb2a529870342b7d95508357402c202cf96b1be7 (diff)
downloadstrongswan-66bb16b0337e326fe9403e65549b0846fd1becaf.tar.bz2
strongswan-66bb16b0337e326fe9403e65549b0846fd1becaf.tar.xz
shipping a default strongswan.conf
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 66c2182e5..3ed61dfc7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = include
+SUBDIRS = . include
if USE_FILE_CONFIG
SUBDIRS += libfreeswan starter ipsec _copyright
@@ -39,3 +39,8 @@ if USE_MANAGER
SUBDIRS += manager
endif
+EXTRA_DIST = strongswan.conf
+
+install-exec-local :
+ test -e "$(DESTDIR)${sysconfdir}" || $(MKDIR_P) "$(DESTDIR)$(sysconfdir)"
+ test -e "$(DESTDIR)$(sysconfdir)/strongswan.conf" || $(INSTALL) -m 600 strongswan.conf $(DESTDIR)$(sysconfdir)/strongswan.conf